summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Hernberg2015-06-13 21:55:22 +0200
committerJoakim Hernberg2015-06-13 21:55:22 +0200
commit40933403f1f6e75df663ea9391bc511b76a4731c (patch)
tree0bea3d2f563d906919aa0c90f4d4dc08295b5e0c
parentf62c1d7fafeb5e3e242b883f1b132b39da84de99 (diff)
downloadaur-40933403f1f6e75df663ea9391bc511b76a4731c.tar.gz
fix problem with install file, shouldn't be an array
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
-rw-r--r--linux-rt.install37
3 files changed, 42 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 717c12ddca54..0e0cfe40ab8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by makepkg 4.2.1
-# Fri Jun 12 16:40:09 UTC 2015
+# Sat Jun 13 19:53:32 UTC 2015
pkgbase = linux-rt
pkgver = 4.0.5_rt3
- pkgrel = 1
+ pkgrel = 2
url = http://www.kernel.org/
arch = i686
arch = x86_64
@@ -38,6 +38,7 @@ pkgbase = linux-rt
pkgname = linux-rt
pkgdesc = The Linux-rt kernel and modules
+ install = linux-rt.install
depends = coreutils
depends = linux-firmware
depends = kmod
diff --git a/PKGBUILD b/PKGBUILD
index 048e0cd1df63..fb3601492c2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _srcname=linux-4.0
_pkgver=4.0.5
_rtpatchver=rt3
pkgver=${_pkgver}_${_rtpatchver}
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.kernel.org/"
license=('GPL2')
@@ -119,7 +119,7 @@ _package() {
conflicts=("kernel26${_kernelname}")
replaces=("kernel26${_kernelname}")
backup=("etc/mkinitcpio.d/${pkgbase}.preset")
- install=("${pkgbase}.install")
+ install="${pkgbase}.install"
cd "${srcdir}/${_srcname}"
diff --git a/linux-rt.install b/linux-rt.install
new file mode 100644
index 000000000000..ef42413835ac
--- /dev/null
+++ b/linux-rt.install
@@ -0,0 +1,37 @@
+# arg 1: the new package version
+# arg 2: the old package version
+
+KERNEL_NAME=
+KERNEL_VERSION=
+
+post_install () {
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+}
+
+post_upgrade() {
+ if findmnt --fstab -uno SOURCE /boot &>/dev/null && ! mountpoint -q /boot; then
+ echo "WARNING: /boot appears to be a separate partition but is not mounted."
+ fi
+
+ # updating module dependencies
+ echo ">>> Updating module dependencies. Please wait ..."
+ depmod ${KERNEL_VERSION}
+ echo ">>> Generating initial ramdisk, using mkinitcpio. Please wait..."
+ mkinitcpio -p linux${KERNEL_NAME}
+
+ if [ $(vercmp $2 3.13) -lt 0 ]; then
+ echo ">>> WARNING: AT keyboard support is no longer built into the kernel."
+ echo ">>> In order to use your keyboard during early init, you MUST"
+ echo ">>> include the 'keyboard' hook in your mkinitcpio.conf."
+ fi
+}
+
+post_remove() {
+ # also remove the compat symlinks
+ rm -f boot/initramfs-linux${KERNEL_NAME}.img
+ rm -f boot/initramfs-linux${KERNEL_NAME}-fallback.img
+}