summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2020-10-21 22:02:05 +0200
committerDavid Runge2020-10-21 22:02:05 +0200
commit701344862ed5f7dc104d27af0c043af26d49ed89 (patch)
treefd97d8313e99e3c694f5e2fe61a854c58482c4b2
parent85fbabbd68f3a0e07ec6a4059ca6c767aa9566bc (diff)
downloadaur-701344862ed5f7dc104d27af0c043af26d49ed89.tar.gz
Rebuild to add all changes from core/linux
PKGBUILD: Incorporate all changes from core/linux.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d224e3ad26f3..72752fdbe810 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-rt
pkgdesc = Linux RT
pkgver = 5.9.1.18.arch1
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.linuxfoundation.org/realtime/start
arch = x86_64
license = GPL2
@@ -35,6 +35,10 @@ pkgname = linux-rt
depends = kmod
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
+ provides = VIRTUALBOX-GUEST-MODULES
+ provides = WIREGUARD-MODULE
+ replaces = virtualbox-guest-modules-arch
+ replaces = wireguard-arch
pkgname = linux-rt-headers
pkgdesc = Headers and scripts for building modules for the Linux RT kernel
diff --git a/PKGBUILD b/PKGBUILD
index ec00a828d528..ef9b02793552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=linux-rt
pkgver=5.9.1.18.arch1
-pkgrel=1
+pkgrel=2
pkgdesc='Linux RT'
arch=('x86_64')
url="https://wiki.linuxfoundation.org/realtime/start"
@@ -71,6 +71,8 @@ _package() {
depends=(coreutils initramfs kmod)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
+ provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE)
+ replaces=(virtualbox-guest-modules-arch wireguard-arch)
cd "${pkgbase}"
local kernver="$(<version)"
@@ -85,7 +87,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
@@ -161,6 +163,9 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ echo "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
+
echo "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"