summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2019-04-13 16:11:32 +0200
committerPiotr Gorski2019-04-13 16:11:32 +0200
commit577c35aa0c06c09a85813b1c4dbfdcd340356fbc (patch)
tree8b1f9fe2943beb4db969c8b04102f959635fa720
parentca084fd53d19dc56fc1d7a30b8d880932c2b657e (diff)
downloadaur-577c35aa0c06c09a85813b1c4dbfdcd340356fbc.tar.gz
Revert FS#59688 - Install HTML docs
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 4 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0adf8339592..c64b7600c1e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-uksm
pkgver = 5.0.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dolohow/uksm
arch = x86_64
license = GPL2
@@ -8,8 +8,6 @@ pkgbase = linux-uksm
makedepends = inetutils
makedepends = bc
makedepends = libelf
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.0.7.tar.xz
source = https://www.kernel.org/pub/linux/kernel/v5.x/linux-5.0.7.tar.sign
diff --git a/PKGBUILD b/PKGBUILD
index 3545c2499053..f05b5bce8ba3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,12 +54,12 @@ _major=5.0
_minor=7
pkgver=${_major}.${_minor}
_srcname=linux-${pkgver}
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/dolohow/uksm"
license=('GPL2')
options=('!strip')
-makedepends=('kmod' 'inetutils' 'bc' 'libelf' 'python-sphinx' 'graphviz')
+makedepends=('kmod' 'inetutils' 'bc' 'libelf')
#_lucjanpath="https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/${_major}"
_lucjanpath="https://gitlab.com/sirlucjan/kernel-patches/raw/master/${_major}"
#_uksm_path="https://raw.githubusercontent.com/dolohow/uksm/master/v4.x"
@@ -193,7 +193,7 @@ prepare() {
build() {
cd ${_srcname}
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -350,18 +350,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"