summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuce2022-05-22 18:52:00 -0500
committerBuce2022-05-22 18:52:00 -0500
commit060bde332c396137d60a2be042b48732ae94de22 (patch)
treef74eceb476d0acf8af60559baeda611c3e443568
downloadaur-macrobe.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb355e05ce6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = macrobe
+ pkgdesc = Companion scripts for xmacro.
+ pkgver = 0.r63.g5b910f4
+ pkgrel = 1
+ url = https://github.com/DMBuce/macrobe
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = xmacro
+ depends = perl
+ depends = bash
+ source = macrobe::git+https://github.com/DMBuce/macrobe.git
+ md5sums = SKIP
+
+pkgname = macrobe
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d8c503e529c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+macrobe/
+src/
+pkg/
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..408d72119f06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Buce <dmbuce@gmail.com>
+
+pkgname=macrobe
+pkgver=0.r63.g5b910f4
+pkgver() {
+ cd "$srcdir/$pkgname"
+ if ! git describe --tags 2>/dev/null; then
+ echo "0.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ fi | sed 's/-/.r/; s/-/./g'
+}
+pkgrel=1
+pkgdesc="Companion scripts for xmacro."
+arch=(any)
+url="https://github.com/DMBuce/macrobe"
+license=('GPL3')
+groups=()
+depends=(
+ xmacro
+ perl
+ bash
+)
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/DMBuce/${pkgname%-git}.git")
+#source=("$pkgname::git+ssh://git@mantrid/~/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ make prefix=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: