summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArvid Norlander2022-09-29 23:03:23 +0200
committerArvid Norlander2022-09-29 23:07:30 +0200
commit95817740d194f429e194f418c6c7d04d69b37805 (patch)
tree850b8cb4975810ddfa001616d7e6cc3777e9e5cd
downloadaur-macutils-git.tar.gz
Create repository
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..694ebad7f6d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = macutils-git
+ pkgdesc = Converting and decompressing some old Macintosh-oriented archive formats
+ pkgver = v2.0b4.r0.58b0225
+ pkgrel = 1
+ url = http://fileformats.archiveteam.org/wiki/Macutil
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ source = macutils::git+https://github.com/VorpalBlade/macutils#branch=modernization
+ md5sums = SKIP
+
+pkgname = macutils-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..025867b64c03
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.log
+*.tar.zst
+/macutils/
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..525f57e4e1e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Arvid Norlander <VorpalBlade (at) users DOT noreply DOT github DOT com>
+pkgname=macutils-git
+pkgver=v2.0b4.r0.58b0225
+pkgrel=1
+pkgdesc="Converting and decompressing some old Macintosh-oriented archive formats"
+arch=(x86_64)
+url="http://fileformats.archiveteam.org/wiki/Macutil"
+license=('GPL')
+makedepends=('git' 'meson')
+source=('macutils::git+https://github.com/VorpalBlade/macutils#branch=modernization')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir"
+ arch-meson "${pkgname%-git}" "build"
+ meson compile -C "build"
+}
+
+package() {
+ cd "$srcdir"
+ meson install -C "build" --destdir "$pkgdir"
+}