summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2019-09-03 18:50:49 +0200
committerbartus2019-09-03 18:50:49 +0200
commitc231da3060dc6b2e14ab1e785c0792f022ade73e (patch)
tree5d509bca59ea8c16bcfe9b9c0c9084c164bc04c7
parent67774405537cea9c8309cbf61a9373e833654840 (diff)
downloadaur-c231da3060dc6b2e14ab1e785c0792f022ade73e.tar.gz
Pop pkgrel to rebuild after package splited.
Drop idea for check() function as magma testing took ~24h to complete * remove checkdepends * fix $optdepends (testing and examples requires python2)
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD5
2 files changed, 3 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 111239249f06..c4c5c9910c69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = magma
pkgdesc = Provides a dense linear algebra library similar to LAPACK but for heterogeneous/hybrid architectures, starting with current 'Multicore+GPU' systems (with CUDA)
pkgver = 2.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://icl.cs.utk.edu/magma/
arch = x86_64
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index d6861a1840f8..f414c24ada38 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,12 +18,11 @@
pkgname=(magma magma-libs)
pkgver=2.5.1
((TRAVIS)) && pkgver=2.5.0 # downgrade to prevernt time out.
-pkgrel=1
+pkgrel=2
pkgdesc="Provides a dense linear algebra library similar to LAPACK but for heterogeneous/hybrid architectures, starting with current 'Multicore+GPU' systems (with CUDA)"
arch=('x86_64')
url="https://icl.cs.utk.edu/magma/"
license=('custom')
-checkdepends=('python')
makedepends=('gcc-fortran' 'cmake' 'blas' 'lapack' 'cuda')
options=('staticlibs')
source=("http://icl.cs.utk.edu/projectsfiles/${pkgname}/downloads/${pkgname}-${pkgver}.tar.gz")
@@ -59,7 +58,7 @@ build() {
package_magma() {
pkgdesc+=" [static libraries and headers]"
depends=(magma-libs)
- optdepends=('python: for examples and tests')
+ optdepends=('python2: for examples and tests')
cd ${srcdir}/magma-${pkgver}/build-static # "$dir"
# do not build test
sed -i "s/install: preinstall/install: magma_sparse/g" Makefile