summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMr.Smith19742023-10-31 08:44:03 +0300
committerMr.Smith19742023-10-31 08:44:03 +0300
commit3696372a495f54e0480a5de82f582cef4102aafd (patch)
tree6c2dad6f81e88c4f1535bbedf31b0467242d892f
parent3a5ee7ac6935531cc8fb8d35dc34bb538a6f042c (diff)
downloadaur-mathgl.tar.gz
Updated build
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD19
2 files changed, 20 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571fc3ae410f..bd7a8dc38744 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
pkgbase = mathgl
pkgdesc = A library for making high-quality scientific graphics
- pkgver = 2.4.4
- pkgrel = 2
+ pkgver = 8.0.1
+ pkgrel = 1
url = http://mathgl.sourceforge.net
arch = i686
arch = x86_64
license = GPL3
makedepends = cmake
makedepends = swig
- depends = libpng
+ depends = python-numpy
+ depends = texlive-bin
+ depends = texlive-binextra
depends = libharu
- depends = python2
depends = hdf5
- depends = texlive-bin
- depends = texlive-core
- depends = python2-numpy
- depends = freeglut
depends = gsl
- depends = qt5-base
depends = glu
- source = https://sourceforge.net/projects/mathgl/files/mathgl/mathgl%202.4.4/mathgl-2.4.4.tar.gz
- md5sums = cbf9bcb4db6c78bda7902d36b9843d7b
+ depends = qt5-base
+ depends = libpng
+ depends = freeglut
+ source = https://sourceforge.net/projects/mathgl/files/mathgl/mathgl%208.0/mathgl-8.0.1.tar.gz
+ md5sums = e86d414f180f7d3e3f1495aca7134409
pkgname = mathgl
-
diff --git a/PKGBUILD b/PKGBUILD
index e03676cf9f09..240d1dc0cb22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
-# Maintainer : Andres Urquijo <alfagalileox@gmail.com>
+# Contributor : Andres Urquijo <alfagalileox@gmail.com>
+
pkgname=mathgl
-pkgver=2.4.4
-pkgrel=2
+pkgver=8.0.1
+pkgrel=1
pkgdesc="A library for making high-quality scientific graphics"
arch=('i686' 'x86_64')
url="http://${pkgname}.sourceforge.net"
license=('GPL3')
-depends=('libpng' 'libharu' 'python2' 'hdf5' 'texlive-bin' 'texlive-core' 'python2-numpy'
- 'freeglut' 'gsl' 'qt5-base' 'glu')
-makedepends=( 'cmake' 'swig')
-source=("https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgname%20$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('cbf9bcb4db6c78bda7902d36b9843d7b')
+depends=('python-numpy' 'texlive-bin' 'texlive-binextra' 'libharu' 'hdf5' 'gsl' 'glu' 'qt5-base' 'libpng' 'freeglut')
+makedepends=('cmake' 'swig')
+source=("https://sourceforge.net/projects/$pkgname/files/$pkgname/$pkgname%208.0/$pkgname-$pkgver.tar.gz")
+md5sums=('e86d414f180f7d3e3f1495aca7134409')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- [[ -d build ]] || mkdir build && cd build
+ [[ -d build ]] && rm -rf build
+ mkdir build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-Denable-all-widgets=OFF \