summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwcampbell2019-10-23 20:21:19 -0400
committerwcampbell2019-10-23 20:21:19 -0400
commita8f34074b3b38d98c427b6e1d234aae5eeb26693 (patch)
tree74c76f6f37599a8193b522ed724a3a6ea5d7fd91
parent29898811bef626edc3059f4518b8a217b972b206 (diff)
downloadaur-mint-cli-git.tar.gz
Update to v0.1.1
Signed-off-by: wcampbell <wcampbell1995@gmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de03f5757cbc..b27e60f82ae7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mint-cli-git
pkgdesc = cli interface for Intuit Mint using python-mintapi
- pkgver = v0.1.0.r0.g11aad24
+ pkgver = v0.1.1.r0.gd02b7c7
pkgrel = 1
url = https://github.com/userWayneCampbell/mint-cli
arch = any
@@ -13,6 +13,7 @@ pkgbase = mint-cli-git
depends = python-dotenv
depends = python-tabulate-git
depends = python-colorama-git
+ depends = scdoc
source = git+https://github.com/userWayneCampbell/mint-cli.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index cf69334a1b56..052645867877 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Wayne Campbell <wcampbell1995 [at] gmail [dot] com>
pkgname=mint-cli-git
_pkgname=mint-cli
-pkgver=v0.1.0.r0.g11aad24
+pkgver=v0.1.1.r0.gd02b7c7
pkgrel=1
pkgdesc="cli interface for Intuit Mint using python-mintapi"
arch=('any')
url="https://github.com/userWayneCampbell/mint-cli"
license=('GPL')
-depends=('git' 'python' 'python-mintapi' 'chromedriver' 'google-chrome' 'python-dotenv' 'python-tabulate-git' 'python-colorama-git')
+depends=('git' 'python' 'python-mintapi' 'chromedriver' 'google-chrome' 'python-dotenv' 'python-tabulate-git' 'python-colorama-git' 'scdoc')
source=("git+https://github.com/userWayneCampbell/mint-cli.git")
md5sums=('SKIP')
@@ -22,6 +22,7 @@ pkgver() {
package() {
cd "$srcdir/${_pkgname}"
+ make && sudo make install
install -Dm755 "${_pkgname}" "${pkgdir}/usr/local/bin/${_pkgname}"
install --backup=numbered -Dm744 ".env.example" "${pkgdir}/etc/mint-cli/.env"
mkdir -p -m 744 "${pkgdir}/var/lib/mint-cli/data/"