summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-21 16:41:03 -0600
committerMark Wagie2024-03-21 16:41:03 -0600
commit5b8f7c5ce5a4c36f4b3d55bac5ed3d11f0981b01 (patch)
treed940b843653596e9ab9877a76a4a25c81467738d
parent4eb7bbaa2659b9051c3b55cb54e6c299d710aec3 (diff)
downloadaur-mullvad-vpn-cli.tar.gz
2024.1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31df8cf1c3bc..1fd904468ec3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
- pkgver = 2023.6
+ pkgver = 2024.1
pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
@@ -15,8 +15,7 @@ pkgbase = mullvad-vpn-cli
depends = libnftnl
provides = mullvad-vpn
conflicts = mullvad-vpn
- options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=c2f7f75dee35c050540b90c6ebc9084969b1a93b
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=b261238598f0237aaf420354445797a12a45d907
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=d5772339cee9c1a0d7671968746f02499b78e245?signed
validpgpkeys = 225E40C8F1C8DEB7977ABF59F293063FECE2E8ED
validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
diff --git a/PKGBUILD b/PKGBUILD
index 92ec7e5ecff0..484e0f4cb262 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2023.6
+pkgver=2024.1
pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
@@ -12,9 +12,8 @@ depends=('dbus' 'iputils' 'libnftnl')
makedepends=('cargo' 'git' 'go' 'protobuf')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-options=('!lto')
install="${pkgname%-*}.install"
-_tag=c2f7f75dee35c050540b90c6ebc9084969b1a93b # tags/2023.6^0
+_tag=b261238598f0237aaf420354445797a12a45d907 # tags/2024.1^0
_commit=d5772339cee9c1a0d7671968746f02499b78e245
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}" # signed by Oskar Nyberg (raksooo), public key not uploaded yet
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
@@ -26,7 +25,7 @@ validpgpkeys=('225E40C8F1C8DEB7977ABF59F293063FECE2E8ED' # Linus Färnstrand <li
)
pkgver() {
- cd "$srcdir/mullvadvpn-app"
+ cd mullvadvpn-app
git describe --tags | sed 's/-/./g'
}
@@ -49,6 +48,7 @@ prepare() {
build() {
cd mullvadvpn-app
+ CFLAGS+=" -ffat-lto-objects"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target