summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Walch2020-11-03 18:52:49 +0100
committerFlorian Walch2020-11-03 18:52:49 +0100
commit891b3a5ae007625894c3598dede67dca5d794914 (patch)
tree0dad0075baaa2a83266ddcb5323fa269571f20ae
parent8e5e54a23f1daa3efcd1e86b3673f928c1aabda3 (diff)
downloadaur-891b3a5ae007625894c3598dede67dca5d794914.tar.gz
Add dependency on tree-sitter
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ad3e28decf2..84e10843b8e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.4.0.r1426.g4ab7bbf3ea
+ pkgver = 0.4.0.r2116.geee0668818
pkgrel = 1
url = https://neovim.io
install = neovim-git.install
@@ -23,13 +23,14 @@ pkgbase = neovim-git
depends = luajit
depends = msgpack-c
depends = unibilium
+ depends = tree-sitter
optdepends = python2-neovim: for Python 2 plugin support (see :help provider-python)
optdepends = python-neovim: for Python 3 plugin support (see :help provider-python)
optdepends = ruby-neovim: for Ruby plugin support (see :help provider-ruby)
optdepends = xclip: for clipboard support (or xsel) (see :help provider-clipboard)
optdepends = xsel: for clipboard support (or xclip) (see :help provider-clipboard)
optdepends = wl-clipboard: for clipboard support on wayland (see :help clipboard)
- provides = neovim=0.4.0.r1426.g4ab7bbf3ea
+ provides = neovim=0.4.0.r2116.geee0668818
conflicts = neovim
options = !strip
backup = etc/xdg/nvim/sysinit.vim
diff --git a/PKGBUILD b/PKGBUILD
index 1d977251acff..239d699f866e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
pkgname=neovim-git
-pkgver=0.4.0.r1426.g4ab7bbf3ea
+pkgver=0.4.0.r2116.geee0668818
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://neovim.io'
backup=('etc/xdg/nvim/sysinit.vim')
license=('custom:neovim')
-depends=('libluv' 'libtermkey' 'libutf8proc' 'libuv' 'libvterm>=0.1.git5' 'luajit' 'msgpack-c' 'unibilium')
+depends=('libluv' 'libtermkey' 'libutf8proc' 'libuv' 'libvterm>=0.1.git5' 'luajit' 'msgpack-c' 'unibilium' 'tree-sitter')
makedepends=('cmake' 'git' 'gperf' 'lua51-mpack' 'lua51-lpeg')
optdepends=('python2-neovim: for Python 2 plugin support (see :help provider-python)'
'python-neovim: for Python 3 plugin support (see :help provider-python)'