summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA Farzat2024-02-01 15:13:54 +0900
committerA Farzat2024-02-01 15:13:54 +0900
commitadb2b2dbf6b0a0a2b005159fd55e22513a262b0a (patch)
tree217bc5614d27dc9be17f98d605cbd0eec00ef512
parenta59a9627d1ad1f1bd1a4e77396ff7cc99ae3cc30 (diff)
downloadaur-adb2b2dbf6b0a0a2b005159fd55e22513a262b0a.tar.gz
Match version to that output by `nvim -v`
Instead of using tags, fetch the version numbers from CMakeLists.txt, and use `git describe --first-parent` for the commit info.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a7f94d4e185..3e04a8144aa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs
- pkgver = 0.9.0.r3144.g9f15a18fa5
- pkgrel = 3
+ pkgver = 0.10.0.r2250.g6bba4beced
+ pkgrel = 1
url = https://neovim.io
arch = i686
arch = x86_64
@@ -26,7 +26,7 @@ pkgbase = neovim-git
optdepends = xclip: for clipboard support on X11 (or xsel) (see :help clipboard)
optdepends = xsel: for clipboard support on X11 (or xclip) (see :help clipboard)
optdepends = wl-clipboard: for clipboard support on wayland (see :help clipboard)
- provides = neovim=0.9.0
+ provides = neovim=0.10.0
provides = vim-plugin-runtime
conflicts = neovim
backup = etc/xdg/nvim/sysinit.vim
diff --git a/PKGBUILD b/PKGBUILD
index 8b043be9170f..91bfa7de5167 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_pkgname=neovim
pkgname="$_pkgname-git"
-pkgver=0.9.0.r3144.g9f15a18fa5
-pkgrel=3
+pkgver=0.10.0.r2250.g6bba4beced
+pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
arch=(i686 x86_64 armv7h armv6h aarch64)
url='https://neovim.io'
@@ -47,7 +47,10 @@ b2sums=('SKIP'
pkgver() {
cd "$_pkgname"
- git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ local nvim_version nvim_version_git
+ nvim_version="$(sed -nE '/NVIM_VERSION_/ s/.* +([0-9]+)\).*/\1/p' ./CMakeLists.txt | sed ':b;N;$!bb;s/\n/\./g')"
+ nvim_version_git="$(git describe --first-parent --always | sed -E 's/^v[0-9]+.[0-9]+.[0-9]+-//; s/^([0-9]+)-([a-z0-9]+)/\1\.\2/')"
+ printf "%s.r%s\n" "$nvim_version" "$nvim_version_git"
}
build() {