summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA Farzat2024-01-31 10:15:49 +0900
committerA Farzat2024-01-31 12:38:27 +0900
commitba0ad4a697242893dbf393b459d45fdc823d2122 (patch)
treead0bdb9d00c39727753d7e2ccc3e9b1d4dcfc212
parent886308c6028ee11d1c56c5d65c8d9a01cb291e44 (diff)
downloadaur-ba0ad4a697242893dbf393b459d45fdc823d2122.tar.gz
Make the package closer to that in the main repos
Also use tree-sitter-git for now because the one in the repos is not up-to-date enough.
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD99
-rw-r--r--neovim-git-archlinux.vim1
-rw-r--r--neovim-git-sysinit.vim2
-rw-r--r--neovim-git.install16
-rw-r--r--nvimdoc5
-rw-r--r--nvimdoc.hook11
8 files changed, 96 insertions, 79 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3512ba14930e..eeeb7aa884da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = neovim-git
- pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.9.0.r432.g9f9cef1b56
+ pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs
+ pkgver = 0.9.0.r3144.g9f15a18fa5
pkgrel = 1
url = https://neovim.io
- install = neovim-git.install
arch = i686
arch = x86_64
arch = armv7h
@@ -13,32 +12,33 @@ pkgbase = neovim-git
makedepends = cmake
makedepends = git
makedepends = ninja
- depends = glibc
- depends = hicolor-icon-theme
+ makedepends = lua51-mpack
+ makedepends = lua51-lpeg
+ makedepends = unzip
depends = libluv
depends = libtermkey
depends = libuv
- depends = libvterm>=0.3
- depends = lua51-lpeg
+ depends = libvterm>0.1.4
depends = luajit
depends = msgpack-c
- depends = tree-sitter
+ depends = tree-sitter-git
depends = unibilium
- optdepends = python-neovim: for Python 3 plugin support (see :help provider-python)
- optdepends = ruby-neovim: for Ruby plugin support (see :help provider-ruby)
- optdepends = xclip: for X11 clipboard support (or xsel) (see :help provider-clipboard)
- optdepends = xsel: for X11 clipboard support (or xclip) (see :help provider-clipboard)
+ optdepends = python-pynvim: for Python plugin support (see :help python)
+ optdepends = xclip: for clipboard support on X11 (or xsel) (see :help clipboard)
+ optdepends = xsel: for clipboard support on X11 (or xclip) (see :help clipboard)
optdepends = wl-clipboard: for clipboard support on wayland (see :help clipboard)
provides = neovim=0.9.0
provides = vim-plugin-runtime
conflicts = neovim
- options = !strip
backup = etc/xdg/nvim/sysinit.vim
source = git+https://github.com/neovim/neovim.git
- source = neovim-git-archlinux.vim
- source = neovim-git-sysinit.vim
+ source = nvimdoc
+ source = nvimdoc.hook
+ sha512sums = SKIP
+ sha512sums = 22662462c823de243599cdd3483e46ade4ab59b219e907468d34c18e584fe7477548e357ee2ce56bb098cf54b770b108a3511703dd486f0774a65c84af78f6aa
+ sha512sums = 3c6ee1e4646d09c164a2212f9e4d2f53158ff32911b0972e060a395a8d4685334574a7ede995a81680dcc0750cd3327a78beb7904a4bb326b2399d79a8b12d5e
b2sums = SKIP
- b2sums = d0871e240bd9c7de7d898e1fba95364f4c4a12dbb3ac40892bbf93a49eb0e8cc2c8bc1ccae9ea5b700581a185a4df56bd28427d42a7d4b288560207b3951a15d
- b2sums = 6ed647c3a4c0907a60060fa61117d484aa091c69c73dda1f0a99aa4e67870ae2092a2c1057a15ced9fc56b08374ce8a8b86dbe531df777f9ad49302c7a9d3da0
+ b2sums = d31cf81659e238fada8092755eb9be16f77c00a466107eb5770c6c9c32e043c91e6efada7ddb51663716a0e38ffa6e3d0093b3e6833aa961d845c7451a95491e
+ b2sums = 26588b9da6459393076723bdfb8d2b16fed882070f2326bf7c35cd272dee9c18df603afb1ae2254cd0a59eff68189caf04828ef165d5de42c7a4222267604101
pkgname = neovim-git
diff --git a/.gitignore b/.gitignore
deleted file mode 100644
index 51168211446a..000000000000
--- a/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-*
-!.gitignore
-!PKGBUILD
-!*.install
-!.SRCINFO
-!neovim-git-archlinux.vim
-!neovim-git-sysinit.vim
diff --git a/PKGBUILD b/PKGBUILD
index 970a8ae4cba6..da2c63d8ca44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,63 +1,90 @@
-# Maintainer: éclairevoyant
+# Maintainer: A Farzat <a@farzat.xyz>
+# Contributor: éclairevoyant
+# Contributor: Sven-Hendrik Haase <svenstaro@archlinux.org>
+# Contributor: Caleb Maclennan <caleb@alerque.com>
# Contributor: Florian Walch <florian+aur@fwalch.com>
# Contributor: Florian Hahn <flo@fhahn.com>
-# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
_pkgname=neovim
pkgname="$_pkgname-git"
-pkgver=0.9.0.r432.g9f9cef1b56
+pkgver=0.9.0.r3144.g9f15a18fa5
pkgrel=1
-pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
+pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs'
arch=(i686 x86_64 armv7h armv6h aarch64)
url='https://neovim.io'
backup=('etc/xdg/nvim/sysinit.vim')
license=('custom:neovim')
-depends=(glibc hicolor-icon-theme libluv libtermkey libuv 'libvterm>=0.3' lua51-lpeg luajit msgpack-c tree-sitter unibilium)
-makedepends=(cmake git ninja)
-optdepends=('python-neovim: for Python 3 plugin support (see :help provider-python)'
- 'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
- 'xclip: for X11 clipboard support (or xsel) (see :help provider-clipboard)'
- 'xsel: for X11 clipboard support (or xclip) (see :help provider-clipboard)'
- 'wl-clipboard: for clipboard support on wayland (see :help clipboard)')
+depends=(
+ 'libluv'
+ 'libtermkey'
+ 'libuv'
+ 'libvterm>0.1.4'
+ 'luajit'
+ 'msgpack-c'
+ 'tree-sitter-git'
+ 'unibilium'
+)
+makedepends=('cmake' 'git' 'ninja' 'lua51-mpack' 'lua51-lpeg' 'unzip')
+optdepends=(
+ 'python-pynvim: for Python plugin support (see :help python)'
+ 'xclip: for clipboard support on X11 (or xsel) (see :help clipboard)'
+ 'xsel: for clipboard support on X11 (or xclip) (see :help clipboard)'
+ 'wl-clipboard: for clipboard support on wayland (see :help clipboard)'
+)
provides=("$_pkgname=${pkgver/\.r*/}" 'vim-plugin-runtime')
conflicts=("$_pkgname")
-source=("git+https://github.com/neovim/$_pkgname.git"
- "$pkgname-archlinux.vim"
- "$pkgname-sysinit.vim")
+source=(
+ "git+https://github.com/neovim/$_pkgname.git"
+ nvimdoc{,.hook}
+)
+sha512sums=('SKIP'
+ '22662462c823de243599cdd3483e46ade4ab59b219e907468d34c18e584fe7477548e357ee2ce56bb098cf54b770b108a3511703dd486f0774a65c84af78f6aa'
+ '3c6ee1e4646d09c164a2212f9e4d2f53158ff32911b0972e060a395a8d4685334574a7ede995a81680dcc0750cd3327a78beb7904a4bb326b2399d79a8b12d5e')
b2sums=('SKIP'
- 'd0871e240bd9c7de7d898e1fba95364f4c4a12dbb3ac40892bbf93a49eb0e8cc2c8bc1ccae9ea5b700581a185a4df56bd28427d42a7d4b288560207b3951a15d'
- '6ed647c3a4c0907a60060fa61117d484aa091c69c73dda1f0a99aa4e67870ae2092a2c1057a15ced9fc56b08374ce8a8b86dbe531df777f9ad49302c7a9d3da0')
-install=$pkgname.install
-options=(!strip)
+ 'd31cf81659e238fada8092755eb9be16f77c00a466107eb5770c6c9c32e043c91e6efada7ddb51663716a0e38ffa6e3d0093b3e6833aa961d845c7451a95491e'
+ '26588b9da6459393076723bdfb8d2b16fed882070f2326bf7c35cd272dee9c18df603afb1ae2254cd0a59eff68189caf04828ef165d5de42c7a4222267604101')
pkgver() {
- cd $_pkgname
- git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cmake -S"$_pkgname" -Bbuild \
- -GNinja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr
- cmake --build build
+ cd "$_pkgname"
+ cmake \
+ -Bbuild \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DUSE_BUNDLED=OFF \
+ -W no-dev
+ cmake --build build --verbose
}
check() {
- build/bin/nvim --version
- build/bin/nvim --headless -u NONE -i NONE -c ':quit'
+ cd "$_pkgname"
+ ./build/bin/nvim --version
+ ./build/bin/nvim --headless -u NONE -i NONE +q
}
package() {
- # Make Arch vim packages work
- install -Dm644 $pkgname-sysinit.vim "$pkgdir/etc/xdg/nvim/sysinit.vim"
- install -Dm644 $pkgname-archlinux.vim "$pkgdir/usr/share/nvim/archlinux.vim"
+ install -Dm644 -t "$pkgdir/usr/share/libalpm/hooks/" nvimdoc.hook
+ install -Dt "$pkgdir/usr/share/libalpm/scripts/" nvimdoc
- DESTDIR="$pkgdir" cmake --install build
+ cd "$_pkgname"
+ DESTDIR="$pkgdir" cmake --install build
- cd $_pkgname
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 runtime/nvim.desktop -t "$pkgdir/usr/share/applications/"
- install -Dm644 runtime/nvim.appdata.xml -t "$pkgdir/usr/share/metainfo/"
- install -Dm644 runtime/nvim.png -t "$pkgdir/usr/share/pixmaps/"
+ install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 runtime/nvim.desktop -t "${pkgdir}/usr/share/applications/"
+ install -Dm644 runtime/nvim.appdata.xml -t "${pkgdir}/usr/share/metainfo/"
+ install -Dm644 runtime/nvim.png -t "${pkgdir}/usr/share/pixmaps/"
+
+ # Make Arch Vim packages work
+ mkdir -p "${pkgdir}"/etc/xdg/nvim
+ echo "\" This line makes pacman-installed global Arch Linux vim packages work." > "${pkgdir}"/etc/xdg/nvim/sysinit.vim
+ echo "source /usr/share/nvim/archlinux.vim" >> "${pkgdir}"/etc/xdg/nvim/sysinit.vim
+
+ mkdir -p "${pkgdir}"/usr/share/vim
+ echo "set runtimepath+=/usr/share/vim/vimfiles" > "${pkgdir}"/usr/share/nvim/archlinux.vim
}
+
+# vim:set sw=2 sts=2 et:
diff --git a/neovim-git-archlinux.vim b/neovim-git-archlinux.vim
deleted file mode 100644
index 5fd4ff31a179..000000000000
--- a/neovim-git-archlinux.vim
+++ /dev/null
@@ -1 +0,0 @@
-set runtimepath+=/usr/share/vim/vimfiles
diff --git a/neovim-git-sysinit.vim b/neovim-git-sysinit.vim
deleted file mode 100644
index 5cfd5b311f5b..000000000000
--- a/neovim-git-sysinit.vim
+++ /dev/null
@@ -1,2 +0,0 @@
-" This line makes pacman-installed global Arch Linux vim packages work.
-source /usr/share/nvim/archlinux.vim
diff --git a/neovim-git.install b/neovim-git.install
deleted file mode 100644
index 664aafc46e91..000000000000
--- a/neovim-git.install
+++ /dev/null
@@ -1,16 +0,0 @@
-# $1: new package version
-post_install() {
- echo ":: The Neovim executable is called 'nvim'."
- echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
- echo " to get started."
- echo ":: If you have any questions, check the following page first:"
- echo " https://github.com/neovim/neovim/wiki/FAQ"
-}
-
-# $1: new package version
-# $2: old package version
-post_upgrade() {
- echo ":: Check the following page to see whether this upgrade"
- echo " includes any breaking changes:"
- echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
-}
diff --git a/nvimdoc b/nvimdoc
new file mode 100644
index 000000000000..821826f24b30
--- /dev/null
+++ b/nvimdoc
@@ -0,0 +1,5 @@
+#!/bin/bash
+
+for f in /usr/share/nvim/site/pack/dist/start/*/doc/; do
+ /usr/bin/nvim -es "+helptags $f" +q
+done
diff --git a/nvimdoc.hook b/nvimdoc.hook
new file mode 100644
index 000000000000..558907c81ac6
--- /dev/null
+++ b/nvimdoc.hook
@@ -0,0 +1,11 @@
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Operation = Remove
+Type = Path
+Target = usr/share/nvim/site/pack/dist/start/*/doc/
+
+[Action]
+Description = Updating Neovim help tags...
+Exec = /usr/share/libalpm/scripts/nvimdoc
+When = PostTransaction