summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2022-12-28 15:28:52 -0500
committeréclairevoyant2022-12-28 15:37:04 -0500
commitbc261b39a69e0854ec6bb419c93fbb690fffe9b8 (patch)
tree31aadfec5bde72e23eca94a7e66348119371d8cb
parent5e1687e6fb93b1488db89ff2b652915b131b9d79 (diff)
downloadaur-bc261b39a69e0854ec6bb419c93fbb690fffe9b8.tar.gz
neovim-git: remove source renaming, cleanup, split scripts into separate
files Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD66
-rw-r--r--neovim-git-archlinux.vim1
-rw-r--r--neovim-git-sysinit.vim2
-rw-r--r--neovim-git.install16
6 files changed, 55 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70400f1e0d9a..131d85590515 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neovim-git
pkgdesc = Fork of Vim aiming to improve user experience, plugins, and GUIs.
- pkgver = 0.8.0.r339.g75ec1b7208
+ pkgver = 0.8.0.r976.g86a75c79e1
pkgrel = 1
url = https://neovim.io
install = neovim-git.install
@@ -11,10 +11,10 @@ pkgbase = neovim-git
arch = aarch64
license = custom:neovim
makedepends = cmake
- makedepends = ninja
makedepends = git
- makedepends = lua51-mpack
makedepends = lua51-lpeg
+ makedepends = lua51-mpack
+ makedepends = ninja
depends = libluv
depends = libtermkey
depends = libuv
@@ -28,12 +28,16 @@ pkgbase = neovim-git
optdepends = xclip: for X11 clipboard support (or xsel) (see :help provider-clipboard)
optdepends = xsel: for X11 clipboard support (or xclip) (see :help provider-clipboard)
optdepends = wl-clipboard: for clipboard support on wayland (see :help clipboard)
- provides = neovim=0.8.0.r339.g75ec1b7208
+ provides = neovim=0.8.0.r976.g86a75c79e1
provides = vim-plugin-runtime
conflicts = neovim
options = !strip
backup = etc/xdg/nvim/sysinit.vim
- source = neovim-git::git+https://github.com/neovim/neovim.git
- sha256sums = SKIP
+ source = git+https://github.com/neovim/neovim.git
+ source = neovim-git-archlinux.vim
+ source = neovim-git-sysinit.vim
+ b2sums = SKIP
+ b2sums = d0871e240bd9c7de7d898e1fba95364f4c4a12dbb3ac40892bbf93a49eb0e8cc2c8bc1ccae9ea5b700581a185a4df56bd28427d42a7d4b288560207b3951a15d
+ b2sums = 6ed647c3a4c0907a60060fa61117d484aa091c69c73dda1f0a99aa4e67870ae2092a2c1057a15ced9fc56b08374ce8a8b86dbe531df777f9ad49302c7a9d3da0
pkgname = neovim-git
diff --git a/.gitignore b/.gitignore
index 44d319eb49a6..51168211446a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,5 @@
!PKGBUILD
!*.install
!.SRCINFO
+!neovim-git-archlinux.vim
+!neovim-git-sysinit.vim
diff --git a/PKGBUILD b/PKGBUILD
index 3997f39f7b97..555b73efb97c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Contributor: Florian Hahn <flo@fhahn.com>
# Contributor: Sven-Hendrik Haase <svenstaro@gmail.com>
-pkgname=neovim-git
-pkgver=0.8.0.r339.g75ec1b7208
+_pkgname=neovim
+pkgname="$_pkgname-git"
+pkgver=0.8.0.r976.g86a75c79e1
pkgrel=1
pkgdesc='Fork of Vim aiming to improve user experience, plugins, and GUIs.'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
@@ -12,55 +13,52 @@ url='https://neovim.io'
backup=('etc/xdg/nvim/sysinit.vim')
license=('custom:neovim')
depends=('libluv' 'libtermkey' 'libuv' 'libvterm>=0.3' 'luajit' 'msgpack-c' 'tree-sitter' 'unibilium')
-makedepends=('cmake' 'ninja' 'git' 'lua51-mpack' 'lua51-lpeg')
+makedepends=('cmake' 'git' 'lua51-lpeg' 'lua51-mpack' 'ninja')
optdepends=('python-neovim: for Python 3 plugin support (see :help provider-python)'
'ruby-neovim: for Ruby plugin support (see :help provider-ruby)'
'xclip: for X11 clipboard support (or xsel) (see :help provider-clipboard)'
'xsel: for X11 clipboard support (or xclip) (see :help provider-clipboard)'
'wl-clipboard: for clipboard support on wayland (see :help clipboard)')
-source=("${pkgname}::git+https://github.com/neovim/neovim.git")
-sha256sums=('SKIP')
-provides=("neovim=${pkgver}" 'vim-plugin-runtime')
-conflicts=('neovim')
-install=neovim-git.install
+provides=("$_pkgname=$pkgver" 'vim-plugin-runtime')
+conflicts=("$_pkgname")
+source=("git+https://github.com/neovim/$_pkgname.git"
+ "$pkgname-archlinux.vim"
+ "$pkgname-sysinit.vim")
+b2sums=('SKIP'
+ 'd0871e240bd9c7de7d898e1fba95364f4c4a12dbb3ac40892bbf93a49eb0e8cc2c8bc1ccae9ea5b700581a185a4df56bd28427d42a7d4b288560207b3951a15d'
+ '6ed647c3a4c0907a60060fa61117d484aa091c69c73dda1f0a99aa4e67870ae2092a2c1057a15ced9fc56b08374ce8a8b86dbe531df777f9ad49302c7a9d3da0')
+install=$pkgname.install
options=(!strip)
pkgver() {
- cd "${pkgname}"
- git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --abbrev=10 --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cmake -S"${pkgname}" -Bbuild \
- -GNinja \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=/usr
- cmake --build build
+ cmake -S"$_pkgname" -Bbuild \
+ -GNinja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
}
check() {
- cd "${srcdir}/build"
- ./bin/nvim --version
- ./bin/nvim --headless -u NONE -i NONE -c ':quit'
+ build/bin/nvim --version
+ build/bin/nvim --headless -u NONE -i NONE -c ':quit'
}
package() {
- cd "${srcdir}/build"
- DESTDIR="${pkgdir}" cmake --build . --target install
+ # Make Arch vim packages work
+ install -Dm644 $pkgname-sysinit.vim "$pkgdir/etc/xdg/nvim/sysinit.vim"
+ install -Dm644 $pkgname-archlinux.vim "$pkgdir/usr/share/nvim/archlinux.vim"
- cd "${srcdir}/${pkgname}"
- install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/"
- install -Dm644 runtime/nvim.desktop -t "${pkgdir}/usr/share/applications/"
- install -Dm644 runtime/nvim.appdata.xml -t "${pkgdir}/usr/share/metainfo/"
- install -Dm644 runtime/nvim.png -t "${pkgdir}/usr/share/pixmaps/"
+ cd build
+ DESTDIR="$pkgdir" cmake --build . --target install
- # Make Arch vim packages work
- mkdir -p "${pkgdir}"/etc/xdg/nvim
- echo "\" This line makes pacman-installed global Arch Linux vim packages work." > "${pkgdir}"/etc/xdg/nvim/sysinit.vim
- echo "source /usr/share/nvim/archlinux.vim" >> "${pkgdir}"/etc/xdg/nvim/sysinit.vim
-
- mkdir -p "${pkgdir}"/usr/share/vim
- echo "set runtimepath+=/usr/share/vim/vimfiles" > "${pkgdir}"/usr/share/nvim/archlinux.vim
+ cd ../$_pkgname
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 runtime/nvim.desktop -t "$pkgdir/usr/share/applications/"
+ install -Dm644 runtime/nvim.appdata.xml -t "$pkgdir/usr/share/metainfo/"
+ install -Dm644 runtime/nvim.png -t "$pkgdir/usr/share/pixmaps/"
}
-
-# vim:set sw=2 sts=2 et:
diff --git a/neovim-git-archlinux.vim b/neovim-git-archlinux.vim
new file mode 100644
index 000000000000..5fd4ff31a179
--- /dev/null
+++ b/neovim-git-archlinux.vim
@@ -0,0 +1 @@
+set runtimepath+=/usr/share/vim/vimfiles
diff --git a/neovim-git-sysinit.vim b/neovim-git-sysinit.vim
new file mode 100644
index 000000000000..5cfd5b311f5b
--- /dev/null
+++ b/neovim-git-sysinit.vim
@@ -0,0 +1,2 @@
+" This line makes pacman-installed global Arch Linux vim packages work.
+source /usr/share/nvim/archlinux.vim
diff --git a/neovim-git.install b/neovim-git.install
index a903b7ef0492..664aafc46e91 100644
--- a/neovim-git.install
+++ b/neovim-git.install
@@ -1,16 +1,16 @@
# $1: new package version
post_install() {
- echo ":: The Neovim executable is called 'nvim'."
- echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
- echo " to get started."
- echo ":: If you have any questions, check the following page first:"
- echo " https://github.com/neovim/neovim/wiki/FAQ"
+ echo ":: The Neovim executable is called 'nvim'."
+ echo ":: If you are already familiar with Vim, see ':help nvim-from-vim'"
+ echo " to get started."
+ echo ":: If you have any questions, check the following page first:"
+ echo " https://github.com/neovim/neovim/wiki/FAQ"
}
# $1: new package version
# $2: old package version
post_upgrade() {
- echo ":: Check the following page to see whether this upgrade"
- echo " includes any breaking changes:"
- echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
+ echo ":: Check the following page to see whether this upgrade"
+ echo " includes any breaking changes:"
+ echo " https://github.com/neovim/neovim/wiki/Following-HEAD"
}