summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2022-03-21 15:39:31 +0100
committerChristian Hesse2022-03-21 15:39:31 +0100
commite079942edac2a481dbbd2ba608b43da68c7f925e (patch)
tree3351eb315848f89b1eb613f937bb1d38e1c28118
parent5ded14f74c85faca276b4f27ad7275437b7e575f (diff)
downloadaur-nullshell-git.tar.gz
commit nullshell-git 0.0.7.r1.g09a906b-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6eef5135e766..b93076575acb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = nullshell-git
pkgdesc = do nothing but print keep alive characters, can be used for login shell - git checkout
- pkgver = 0.0.6.r0.g967686e
+ pkgver = 0.0.7.r1.g09a906b
pkgrel = 1
url = https://github.com/eworm-de/nullshell
install = nullshell.install
arch = i686
arch = x86_64
license = GPL
- makedepends = markdown
makedepends = git
+ makedepends = discount
conflicts = nullshell
- source = git://github.com/eworm-de/nullshell.git
+ source = git+https://github.com/eworm-de/nullshell.git
sha256sums = SKIP
pkgname = nullshell-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 8b181d6862f6..a1ae47663d3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer: Christian Hesse <mail@eworm.de>
pkgname=nullshell-git
-pkgver=0.0.6.r0.g967686e
+pkgver=0.0.7.r1.g09a906b
pkgrel=1
pkgdesc="do nothing but print keep alive characters, can be used for login shell - git checkout"
arch=('i686' 'x86_64')
-makedepends=('markdown' 'git')
+makedepends=('git' 'discount')
url="https://github.com/eworm-de/nullshell"
conflicts=('nullshell')
license=('GPL')
install=nullshell.install
-source=('git://github.com/eworm-de/nullshell.git')
+source=('git+https://github.com/eworm-de/nullshell.git')
sha256sums=('SKIP')
pkgver() {
cd nullshell/
if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git rev-parse --short HEAD)"
else
- echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git rev-parse --short HEAD)"
fi
}