summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2022-05-24 12:22:42 -0600
committerAlex Szczuczko2022-05-24 12:22:42 -0600
commitbcefe68de7f073c4a860a053ea88eaf9ea3113eb (patch)
tree96ecdd60a13ba9f16036245688695798b9833783
parentd8a777839ef7b961248db84aa967239ed469219d (diff)
downloadaur-bcefe68de7f073c4a860a053ea88eaf9ea3113eb.tar.gz
Add flex and bison to makedepends
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 915cf3614265..f5828bb23d3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed May 15 16:01:27 UTC 2019
+# Tue May 24 18:22:38 UTC 2022
pkgbase = nusmv
pkgdesc = A new symbolic model checker
pkgver = 2.6.0
@@ -13,6 +13,8 @@ pkgbase = nusmv
makedepends = ghostscript
makedepends = texlive-latexextra
makedepends = doxygen
+ makedepends = flex
+ makedepends = bison
depends = libxml2
optdepends = perl: for scripts in /usr/share/nusmv/contrib/
source = http://nusmv.fbk.eu/distrib/NuSMV-2.6.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index ccc90a28b349..74a01e526725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('i686' 'x86_64')
url="http://nusmv.fbk.eu/index.html"
license=('LGPL2.1')
depends=('libxml2')
-makedepends=('cmake' 'python2' 'ghostscript' 'texlive-latexextra' 'doxygen')
+makedepends=('cmake' 'python2' 'ghostscript' 'texlive-latexextra' 'doxygen' 'flex' 'bison')
optdepends=('perl: for scripts in /usr/share/nusmv/contrib/')
source=("http://nusmv.fbk.eu/distrib/${_pkgname}-${pkgver}.tar.gz"
"cmake.patch"
@@ -37,7 +37,7 @@ prepare() {
build() {
cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
- mkdir build
+ mkdir -p build
cd build
cmake .. -DPYTHON_EXECUTABLE=/bin/python2 -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev
make