summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2023-12-01 00:41:54 +0200
committerAdrian Perez de Castro2023-12-01 00:41:54 +0200
commitbff7cb139935224612f668103a1b1ff269035850 (patch)
tree1d75bdc5b20f26a9c52e914778dab641cee9bf66
parente700ab44101e738c432258cadba9a8dab8e8cdac (diff)
downloadaur-office-code-pro.tar.gz
Switch over to fork that fixes actual monospaced metrics
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c2cc32d9892..cfe3f6ee97f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = office-code-pro
pkgdesc = Customized version of Source Code Pro font
- pkgver = 1.004
- pkgrel = 3
- url = https://github.com/nathco/Office-Code-Pro
+ pkgver = 1.004+1
+ pkgrel = 1
+ url = https://github.com/phooky/Office-Code-Pro
arch = any
license = custom: SIL Open Font License 1.1
- source = Office-Code-Pro-1.004.tar.gz::https://github.com/nathco/Office-Code-Pro/archive/1.004.tar.gz
- sha256sums = 9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6
+ makedepends = git
+ source = Office-Code-Pro::git+https://github.com/phooky/Office-Code-Pro#commit=d8fe9b1655a449d5fa4952d8388a626bfd87d652
+ sha256sums = SKIP
pkgname = office-code-pro
-
diff --git a/PKGBUILD b/PKGBUILD
index 42d3f0003b88..f3d58b811119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
# Contributor: Javier Tia <javier.tia@gmail.com>
# otfinfo --info *.otf
_pkgname='Office-Code-Pro'
+_commit='d8fe9b1655a449d5fa4952d8388a626bfd87d652'
pkgname="${_pkgname,,}"
-pkgver=1.004
-pkgrel=3
+pkgver=1.004+1
+pkgrel=1
pkgdesc='Customized version of Source Code Pro font'
arch=('any')
-url='https://github.com/nathco/Office-Code-Pro'
+url="https://github.com/phooky/${_pkgname}"
license=('custom: SIL Open Font License 1.1')
-source=("${_pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
-sha256sums=('9bca923d17f6c47a586d8e4567d46ccfa58fb8b8e2247b5ee2a19da1597c58f6')
+source=("${_pkgname}::git+${url}#commit=${_commit}")
+makedepends=(git)
+sha256sums=(SKIP)
package() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
find 'Fonts' -type f -name "*.otf" -exec install -Dvm644 "{}" -t "${pkgdir}/usr/share/fonts/OTF" \;
install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
install -Dvm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"