summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-10-14 15:01:43 +0200
committerFabioLolix2023-10-14 15:01:43 +0200
commitd6e4ea78b5cdf3f4b1181783ededdb91b3de4a12 (patch)
tree0ea337d111a2795bc98553057a16eb0236085b21
parent30fdf56c2720daa04589309404c34b93a1b8f2f3 (diff)
downloadaur-opendht-git.tar.gz
revision
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD37
2 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 651b84d2f1f3..a7ddc1072fa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = opendht-git
- pkgdesc = C++14 implementation of the Kademlia DHT (Distributed Hash Table)
- pkgver = 2.3.3.r2.gf590980c
+ pkgdesc = C++17 Distributed Hash Table (DHT) implementation
+ pkgver = 3.0.0.r1.g601758f5
pkgrel = 2
epoch = 1
url = https://github.com/savoirfairelinux/opendht
arch = x86_64
arch = i686
arch = pentium4
- arch = arm
- arch = armv6h
arch = armv7h
arch = aarch64
license = GPL3
@@ -17,12 +15,16 @@ pkgbase = opendht-git
makedepends = cmake
makedepends = cython
makedepends = python-setuptools
+ makedepends = cppunit
+ makedepends = asio
depends = gnutls
depends = nettle
depends = readline
- depends = asio
depends = jsoncpp
depends = argon2
+ depends = fmt
+ depends = glibc
+ depends = gcc-libs
optdepends = python: to use the Python bindings
provides = opendht
conflicts = opendht
diff --git a/PKGBUILD b/PKGBUILD
index ffbf8954d20e..2ad81fef3335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=opendht-git
-pkgver=2.3.3.r2.gf590980c
+pkgver=3.0.0.r1.g601758f5
pkgrel=2
epoch=1
-pkgdesc="C++14 implementation of the Kademlia DHT (Distributed Hash Table)"
-arch=(x86_64 i686 pentium4 arm armv6h armv7h aarch64)
+pkgdesc="C++17 Distributed Hash Table (DHT) implementation"
+arch=(x86_64 i686 pentium4 armv7h aarch64)
url="https://github.com/savoirfairelinux/opendht"
license=(GPL3)
-depends=(gnutls nettle readline asio jsoncpp argon2)
-makedepends=(git msgpack-cxx cmake cython python-setuptools )
+depends=(gnutls nettle readline jsoncpp argon2 fmt glibc gcc-libs)
+makedepends=(git msgpack-cxx cmake cython python-setuptools cppunit asio)
optdepends=('python: to use the Python bindings')
provides=(opendht)
conflicts=(opendht)
@@ -20,27 +20,24 @@ sha256sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "${srcdir}/${pkgname%-*}"
- install -d build
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${pkgname%-git}/build"
- cmake .. \
- -DCMAKE_BUILD_TYPE=Release \
- -DOPENDHT_PYTHON=ON \
+ cmake -B build -S "opendht" -Wno-dev \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib
- make
+ -DOPENDHT_PYTHON=ON
+
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
}
package() {
- cd "${srcdir}/${pkgname%-git}/build"
- make DESTDIR="${pkgdir}" install
- install -D -m644 ../README.md "${pkgdir}/usr/share/doc/opendht/README.md"
+ DESTDIR="${pkgdir}" cmake --install build
+ install -D -m644 opendht/README.md "${pkgdir}/usr/share/doc/opendht/README.md"
}