summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2024-04-15 15:05:50 -0400
committerneeshy2024-04-15 15:07:02 -0400
commit912c94810273667a5c1efeca52f23453d677527c (patch)
tree75c78f3133f5994484b79809944248272deba03d
parent02059faa85429424fe287698560c260ab4892840 (diff)
downloadaur-osu-lazer.tar.gz
fix issue with vulkan
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 621e79f2f3b6..a141db274d8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = osu-lazer
pkgdesc = A free-to-win rhythm game. Rhythm is just a *click* away!
pkgver = 2024.412.1
- pkgrel = 1
+ pkgrel = 2
url = https://osu.ppy.sh/
arch = x86_64
license = MIT AND CC-BY-NC-4.0
diff --git a/PKGBUILD b/PKGBUILD
index f066cdee3723..3e76c2a764f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=osu-lazer
_pkgname=osu
pkgver=2024.412.1
-pkgrel=1
+pkgrel=2
pkgdesc="A free-to-win rhythm game. Rhythm is just a *click* away!"
arch=('x86_64')
url="https://osu.ppy.sh/"
@@ -43,4 +43,7 @@ package() {
install -Dm644 assets/lazer-nuget.png "$pkgdir/usr/share/icons/hicolor/128x128/apps/osu-lazer.png"
install -Dm644 assets/lazer.png "$pkgdir/usr/share/icons/hicolor/1024x1024/apps/osu-lazer.png"
install -Dm644 LICENCE "$pkgdir/usr/share/licenses/osu-lazer/LICENCE"
+
+ # Fix Vulkan renderer. See: https://github.com/ppy/osu/discussions/27659#discussioncomment-9101487
+ ln -sf /usr/lib/libdl.so.2 "$pkgdir/opt/osu-lazer/libdl.so"
}