summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeph2021-06-11 00:10:26 +0200
committerZeph2021-06-11 00:10:26 +0200
commit24c3d779dfd8911a0127291dd83a62ec718bd12b (patch)
tree10025b349b84a226c746597c66cb79f9b6d9bab0
parent61a425ffe08f1527b0a0564f16f12994e5bd2fb2 (diff)
downloadaur-24c3d779dfd8911a0127291dd83a62ec718bd12b.tar.gz
V10.1.3 fix pacman 6.0
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--fix-appstream-data.hook14
-rw-r--r--fix-appstream-data.sh10
-rw-r--r--pamac.install57
5 files changed, 14 insertions, 123 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d75930e1fd02..eaa2e17d32b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pamac-aur
pkgdesc = A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support
- pkgver = 10.1.2
+ pkgver = 10.1.3
pkgrel = 1
- url = https://gitlab.manjaro.org/applications/pamac
+ url = https://gitlab.manjaro.org/applications
install = pamac.install
arch = i686
arch = x86_64
@@ -30,7 +30,7 @@ pkgbase = pamac-aur
depends = gtk3>=3.22
depends = libnotify
depends = desktop-file-utils
- depends = pacman>=5.2
+ depends = libpamac-aur
depends = gnutls>=3.4
depends = git
depends = appstream-glib>=0.7.18-1
@@ -39,18 +39,12 @@ pkgbase = pamac-aur
depends = git
optdepends = polkit-gnome: needed for authentification in Cinnamon, Gnome
optdepends = lxsession: needed for authentification in Xfce, LXDE etc.
- provides = pamac=10.1.2-1
+ provides = pamac=10.1.3-1
conflicts = pamac
conflicts = pamac-tray-appindicator
options = !emptydirs
options = !strip
- backup = etc/pamac.conf
- source = pamac-10.1.2-1.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/bd6b8e8cf727cf94a1c9f4467a9157d94cad781f/pamac-bd6b8e8cf727cf94a1c9f4467a9157d94cad781f.tar.gz
- source = fix-appstream-data.sh
- source = fix-appstream-data.hook
- sha256sums = 9f172520c904ed79dd831f84b96dbe28a96d132391889fbf8207c98589221921
- sha256sums = e9fe7c14d15cbce1d337749cf317e4460bce485b102b5c228b7efa479998d4fa
- sha256sums = c2b943318a01ba1f3dabbf32e48e6a6f4b4b774e167ab86c6bfee31aa4a3424c
+ source = pamac-10.1.3-1.tar.gz::https://gitlab.manjaro.org/applications/pamac/-/archive/b7837bb4fd517e0288e744af0ef773b325128196/pamac-b7837bb4fd517e0288e744af0ef773b325128196.tar.gz
+ sha256sums = cf5304bdab2d9f2682a21ee918b44de4b148eb107c440cd382855c0d6954113e
pkgname = pamac-aur
-
diff --git a/PKGBUILD b/PKGBUILD
index f48b02af4add..70442cdcd710 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,31 @@
# Contributor: Zeph <zeph33@gmail.com>
# Maintainer: Zeph <zeph33@gmail.com>
# https://gitlab.manjaro.org/packages/extra/pamac
-ENABLE_FLATPAK=0
-ENABLE_SNAPD=0
pkgname=pamac-aur
-pkgver=10.1.2
+pkgver=10.1.3
pkgrel=1
_pkgfixver=$pkgver
-_commit='bd6b8e8cf727cf94a1c9f4467a9157d94cad781f'
-sha256sums=('9f172520c904ed79dd831f84b96dbe28a96d132391889fbf8207c98589221921'
- 'e9fe7c14d15cbce1d337749cf317e4460bce485b102b5c228b7efa479998d4fa'
- 'c2b943318a01ba1f3dabbf32e48e6a6f4b4b774e167ab86c6bfee31aa4a3424c')
+_commit='b7837bb4fd517e0288e744af0ef773b325128196'
+sha256sums=('cf5304bdab2d9f2682a21ee918b44de4b148eb107c440cd382855c0d6954113e')
pkgdesc="A Gtk3 frontend, Package Manager based on libalpm with AUR and Appstream support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://gitlab.manjaro.org/applications/pamac"
+url="https://gitlab.manjaro.org/applications"
license=('GPL3')
depends=('glib2>=2.42' 'json-glib' 'libsoup' 'dbus-glib' 'polkit' 'vte3>=0.38' 'gtk3>=3.22'
- 'libnotify' 'desktop-file-utils' 'pacman>=5.2' 'gnutls>=3.4' 'git'
+ 'libnotify' 'desktop-file-utils' 'libpamac-aur' 'gnutls>=3.4' 'git'
'appstream-glib>=0.7.18-1' 'archlinux-appstream-data' 'libhandy' 'git')
optdepends=('polkit-gnome: needed for authentification in Cinnamon, Gnome'
'lxsession: needed for authentification in Xfce, LXDE etc.')
makedepends=('gettext' 'itstool' 'vala>=0.46' 'gtk3>=3.22' 'asciidoc' 'meson' 'ninja' 'gobject-introspection' 'libappindicator-gtk3' 'xorgproto')
-backup=('etc/pamac.conf')
conflicts=('pamac' 'pamac-tray-appindicator')
provides=("pamac=$pkgver-$pkgrel")
options=(!emptydirs !strip)
-
install=pamac.install
-source=("pamac-$pkgver-$pkgrel.tar.gz::$url/-/archive/$_commit/pamac-$_commit.tar.gz"
- fix-appstream-data.sh fix-appstream-data.hook)
-define_meson=''
-if [ "${ENABLE_FLATPAK}" = 1 ]; then
- depends+=('flatpak')
- define_meson+=' -Denable-flatpak=true'
-fi
-
-if [ "${ENABLE_SNAPD}" = 1 ]; then
- depends+=('snapd' 'snapd-glib')
- define_meson+=' -Denable-snap=true'
-fi
+source=("pamac-$pkgver-$pkgrel.tar.gz::$url/pamac/-/archive/$_commit/pamac-$_commit.tar.gz")
prepare() {
cd "$srcdir/pamac-$_commit"
@@ -57,18 +40,13 @@ build() {
meson --buildtype=release \
--prefix=/usr \
-Denable-appindicator=true \
- --sysconfdir=/etc $define_meson
- # build
+ --sysconfdir=/etc
ninja
}
package() {
cd "$srcdir/pamac-$_commit/builddir"
-
DESTDIR="$pkgdir" ninja install
- # cp -r "$srcdir/pamac-$_commit/data/gnome-shell/pamac-updates@manjaro.org" "$pkgdir/usr/share/gnome-shell/extensions"
- # fix appstream issue
- install -Dm644 "$srcdir/fix-appstream-data.hook" "$pkgdir/etc/pacman.d/hooks/fix-appstream-data.hook"
- install -Dm755 "$srcdir/fix-appstream-data.sh" "$pkgdir/etc/pacman.d/hooks.bin/fix-appstream-data.sh"
+ cp -r "$srcdir/pamac-$_commit/data/gnome-shell/pamac-updates@manjaro.org" "$pkgdir/usr/share/gnome-shell/extensions"
}
# vim:set ts=2 sw=2 et:
diff --git a/fix-appstream-data.hook b/fix-appstream-data.hook
deleted file mode 100644
index 9bdff11a3a3e..000000000000
--- a/fix-appstream-data.hook
+++ /dev/null
@@ -1,14 +0,0 @@
-[Trigger]
-Operation = Install
-Operation = Upgrade
-Type = Path
-Target = usr/share/app-info/xmls/*.xml.gz
-
-# attention: hook name before: update-appstream-cache.hook
-
-[Action]
-Description = fix appstream datas for pamac
-When = PostTransaction
-Depends = gzip
-Exec = /etc/pacman.d/hooks.bin/fix-appstream-data.sh
-NeedsTargets
diff --git a/fix-appstream-data.sh b/fix-appstream-data.sh
deleted file mode 100644
index e6c365c059b5..000000000000
--- a/fix-appstream-data.sh
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/bash
-tmp="/tmp/fix-appstream-data"
-while read -r archive; do
- if [[ $(zcat "${archive}" | grep -cm1 '<em>') == "1" ]]; then
- zcat "${archive}" | sed 's|<em>||g;s|<\/em>||g;s|<strong>||g;s|<\/strong>||g' | gzip > "${tmp}"
- cp "${tmp}" "${archive}"
- rm "${tmp}"
- echo " archive ${archive} fixed"
- fi
-done
diff --git a/pamac.install b/pamac.install
index 524f2455707c..471206c11b1a 100644
--- a/pamac.install
+++ b/pamac.install
@@ -1,64 +1,7 @@
-msg() {
- ALL_OFF="\e[1;0m"
- BOLD="\e[1;1m"
- GREEN="${BOLD}\e[1;32m"
- local mesg=$1; shift
- printf "${GREEN}==>${ALL_OFF}${BOLD} ${mesg}${ALL_OFF}\n" "$@" >&2
-}
-
-restore_conf() {
- PAMAC_NEW="$(date +%m%d%M%S)"
- if [ -f "/etc/pamac.conf.pacsave" ]; then
- msg "You had an old /etc/pamac.conf.pacsave file. We restore it for you."
- msg "You can find your new pamac.conf saved as \`/etc/pamac-new-${PAMAC_NEW}.conf\`"
- mv /etc/pamac.conf /etc/pamac-new-${PAMAC_NEW}.conf
- mv /etc/pamac.conf.pacsave /etc/pamac.conf
- fi
-}
-
post_install() {
- # enable flatpak repo
- if [ -f /usr/bin/flatpak ]; then
- flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
- fi
- # enable systemd timers
- mkdir -p /etc/systemd/system/timers.target.wants
- ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
- # polkit agent
printf '==> An authentication agent is required\n'
printf ' Cinnamon, Deepin, GNOME, GNOME Flashback, KDE, LXDE, LXQt, MATE and Xfce\n'
printf ' have an authentication agent already.\n'
printf ' See https://wiki.archlinux.org/index.php/Polkit#Authentication_agents\n'
printf ' for other desktop environments.\n'
- # restore old conf
- restore_conf
-}
-
-post_upgrade() {
- # enable flatpak repo
- if [ -f /usr/bin/flatpak ]; then
- flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
- fi
- # restore old conf
- if [ "$(vercmp $2 7.3.5-3)" -lt 0 ]; then
- restore_conf
- fi
-
- if [ "$(vercmp $2 8.0.3-5)" -lt 0 ]; then
- # remove wrong placed symlinks
- msg "Updating timer symlinks"
- [[ -e /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer ]] && rm -f /etc/systemd/system/multi-user.target.wants/pamac-cleancache.timer
- # [[ -e /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer ]] && rm -f /etc/systemd/system/multi-user.target.wants/pamac-mirrorlist.timer
- # enable systemd timers
- mkdir -p /etc/systemd/system/timers.target.wants
- ln -sf /usr/lib/systemd/system/pamac-cleancache.timer /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # ln -sf /usr/lib/systemd/system/pamac-mirrorlist.timer /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
- fi
-}
-
-post_remove() {
- # disable systemd timers
- rm -f /etc/systemd/system/timers.target.wants/pamac-cleancache.timer
- # rm -f /etc/systemd/system/timers.target.wants/pamac-mirrorlist.timer
}