summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2021-06-26 13:32:10 +0300
committerAnton Leontiev2021-06-26 13:32:10 +0300
commit211136795ad21cb085c7d36c30897a0847595a22 (patch)
tree533bd97288a2f33e0ed760d19cc05dad4f4f1db9
parent507a2f226bf4aea116f4c38d8e6cf2d79eb0cc03 (diff)
downloadaur-perl-text-lorem.tar.gz
Add patch to install executable files
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
-rw-r--r--PKGBUILD.tt8
-rw-r--r--exe-files.patch12
4 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 525b77cfd520..fbfc6c0f9274 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-text-lorem
pkgdesc = Perl package and tool to generate random Latin looking text
pkgver = 0.34
- pkgrel = 1
+ pkgrel = 2
url = https://metacpan.org/release/Text-Lorem
arch = any
license = PerlArtistic
@@ -9,7 +9,8 @@ pkgbase = perl-text-lorem
depends = perl
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/A/AD/ADEOLA/Text-Lorem-0.34.tar.gz
+ source = exe-files.patch
md5sums = 18837055204e72bcb56d972c912795c7
+ md5sums = a9d153694858a8ecee0695c84cd54d24
pkgname = perl-text-lorem
-
diff --git a/PKGBUILD b/PKGBUILD
index ab11d7ff639e..c55a3e1abc08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,25 @@
pkgname=perl-text-lorem
pkgver=0.34
-pkgrel=1
+pkgrel=2
pkgdesc='Perl package and tool to generate random Latin looking text'
arch=('any')
url='https://metacpan.org/release/Text-Lorem'
license=('PerlArtistic' 'GPL')
depends=('perl')
-source=(http://search.cpan.org/CPAN/authors/id/A/AD/ADEOLA/Text-Lorem-0.34.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/A/AD/ADEOLA/Text-Lorem-0.34.tar.gz exe-files.patch)
options=(!emptydirs)
-md5sums=('18837055204e72bcb56d972c912795c7')
+md5sums=('18837055204e72bcb56d972c912795c7' a9d153694858a8ecee0695c84cd54d24)
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1
}
+prepare() {
+ patch -d Text-Lorem-0.34 -p1 < exe-files.patch
+}
+
build() {
cd Text-Lorem-0.34
sanitize
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index a8f49f2b9df7..631f80b3446f 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -10,15 +10,19 @@ arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
depends=('perl')
-source=([% source %])
+source=([% source %] exe-files.patch)
options=(!emptydirs)
-md5sums=('[% md5sums %]')
+md5sums=('[% md5sums %]' a9d153694858a8ecee0695c84cd54d24)
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1
}
+prepare() {
+ patch -d [% distdir %] -p1 < exe-files.patch
+}
+
build() {
cd [% distdir %]
sanitize
diff --git a/exe-files.patch b/exe-files.patch
new file mode 100644
index 000000000000..478e7854d96e
--- /dev/null
+++ b/exe-files.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index 35b1818..1e25ffe 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -12,6 +12,7 @@ WriteMakefile(
+ TEST_REQUIRES => {
+ 'Test::More' => 0,
+ },
++ EXE_FILES => [ 'bin/lorem' ],
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {