summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2022-03-31 13:18:41 +0200
committerGilrain2022-03-31 13:18:41 +0200
commitc099af979837cb7ed514f8977d1a09499235b90c (patch)
tree1183478769d825af647279a2a26ec58e28c47f1c
parentc3d5546ca3e96ab301b46e1eb4afadeefff22f54 (diff)
downloadaur-pgl.tar.gz
patch for blocklist build (https://bugs.gentoo.org/707944)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 254b9f931600..12ac8d5c106e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -33,6 +33,8 @@ pkgbase = pgl
backup = etc/logrotate.d/pglcmd
backup = etc/logrotate.d/pgld
source = https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/2.3.1/pgl-2.3.1.tar.gz
+ source = pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4
sha1sums = a91c0c49cdbf78aa6cc1d93b8ed6843290460520
+ sha1sums = 17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79
pkgname = pgl
diff --git a/PKGBUILD b/PKGBUILD
index 051c22793bdc..a2cc26f4101e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,8 +22,16 @@ backup=('etc/pgl/allow.p2p'
'etc/logrotate.d/pglcmd'
'etc/logrotate.d/pgld')
changelog=changelog
-source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz")
-sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520')
+source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/$pkgname-$pkgver.tar.gz"
+ "pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4")
+sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520'
+ '17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../pglinux-2.3.1_p20171006-fno-common.patch
+}
build() {
cd "$pkgname-$pkgver"