diff options
author | Mark Wagie | 2024-09-26 13:21:23 -0600 |
---|---|---|
committer | Mark Wagie | 2024-09-26 13:21:23 -0600 |
commit | 1f3558bc894a4019998f43a7fb635862c56ba8d0 (patch) | |
tree | 596240dffa4233ddd215aae4ddc91ec4c7067f10 | |
parent | dc9dbcfb8e1fde6c6685b3b097102002b905a5f2 (diff) | |
download | aur-pop-launcher-git.tar.gz |
fix build with LTO
-rw-r--r-- | .SRCINFO | 5 | ||||
-rw-r--r-- | PKGBUILD | 13 |
2 files changed, 9 insertions, 9 deletions
@@ -1,13 +1,15 @@ pkgbase = pop-launcher-git pkgver = 1.2.1.r66.g6a1b8b9 - pkgrel = 2 + pkgrel = 3 url = https://github.com/pop-os/launcher arch = x86_64 arch = aarch64 license = MPL-2.0 makedepends = cargo + makedepends = clang makedepends = git makedepends = just + makedepends = lld depends = dbus depends = fd depends = libqalculate @@ -16,7 +18,6 @@ pkgbase = pop-launcher-git depends = pop-icon-theme-git depends = sh depends = xdg-utils - options = !lto source = git+https://github.com/pop-os/launcher.git sha256sums = SKIP @@ -1,11 +1,8 @@ # Maintainer: Mark Wagie <mark dot wagie at proton dot me> - -## TODO: Fix build with LTO - pkgname=('pop-launcher-git' 'pop-shell-plugin-system76-power-git') pkgbase=pop-launcher-git pkgver=1.2.1.r66.g6a1b8b9 -pkgrel=2 +pkgrel=3 arch=('x86_64' 'aarch64') url="https://github.com/pop-os/launcher" license=('MPL-2.0') @@ -21,10 +18,11 @@ depends=( ) makedepends=( 'cargo' + 'clang' 'git' 'just' + 'lld' ) -options=('!lto') source=('git+https://github.com/pop-os/launcher.git') sha256sums=('SKIP') @@ -39,13 +37,14 @@ prepare() { cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')" # Use thin LTO objects -# sed -i 's/lto = "fat"/lto = "thin"/' Cargo.toml + sed -i 's/lto = "fat"/lto = "thin"/g' Cargo.toml } build() { cd launcher export RUSTUP_TOOLCHAIN=stable - just build-release --frozen + RUSTFLAGS+=" -C link-arg=-fuse-ld=lld" + CC=clang just build-release --frozen } check() { |