summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRex2020-03-12 11:54:06 +0800
committerRex2020-03-12 11:54:06 +0800
commita68ff7a65b7543e0611bf8e69edc85d5b2f1d7a1 (patch)
tree64d742436041a7dc1d486c09f135e2aa7734a12a
parent5396c1cb5900faa80e6362cbc6671ef7eb116c25 (diff)
downloadaur-pop-shell-theme-git.tar.gz
updated PKGBUILD
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 782f7b7ae766..c3a16b1f4c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pop-shell-theme-git
pkgdesc = This is the GNOME Shell theme that goes along with the Pop GTK Theme.
- pkgver = r98.21a1337
- pkgrel = 2
+ pkgver = r182.8c7ef1b
+ pkgrel = 1
url = https://github.com/pop-os/gnome-shell-theme
arch = any
license = GPL2
@@ -23,7 +23,6 @@ pkgbase = pop-shell-theme-git
optdepends = ttf-fira-sans: Recommended font for window titles and interface
optdepends = ttf-fira-mono: Recommended monospace font
optdepends = ttf-roboto-slab: Recommended font for documents
- optdepends = pop-gtk-theme-git: Recommended gtk theme
optdepends = pop-icon-theme-git: Recommended icon theme
provides = gnome-shell-theme
conflicts = gnome-shell-theme
diff --git a/PKGBUILD b/PKGBUILD
index a3d954a9bdab..be6fc43c5d88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=pop-shell-theme-git
_pkgname=gnome-shell-theme
-pkgver="r98.21a1337"
-pkgrel=2
+pkgver=r182.8c7ef1b
+pkgrel=1
pkgdesc="This is the GNOME Shell theme that goes along with the Pop GTK Theme."
arch=("any")
url="https://github.com/pop-os/gnome-shell-theme"
@@ -30,7 +30,6 @@ optdepends=(
"ttf-fira-sans: Recommended font for window titles and interface"
"ttf-fira-mono: Recommended monospace font"
"ttf-roboto-slab: Recommended font for documents"
- "pop-gtk-theme-git: Recommended gtk theme"
"pop-icon-theme-git: Recommended icon theme"
)
provides=("${_pkgname}")
@@ -38,6 +37,11 @@ conflicts=("${_pkgname}")
source=("git+https://github.com/pop-os/gnome-shell-theme.git")
sha256sums=("SKIP")
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
build() {
cd "${_pkgname}"
make clean