summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Araps2019-02-09 17:22:57 +0200
committerDylan Araps2019-02-09 17:22:57 +0200
commit00bca4003f996552c758bcfa63a67c806ed31448 (patch)
treee7204c25360491aff1fa538b4ffd6f24e6542b53
downloadaur-promptless.tar.gz
install
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cad2677b27db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sat Feb 9 15:20:55 UTC 2019
+pkgbase = promptless
+ pkgdesc = A super fast and extremely minimal shell prompt.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/dylanaraps/promptless
+ arch = any
+ license = MIT
+ makedepends = git
+ provides = promptless
+ conflicts = promptless
+ source = promptless::git+https://github.com/dylanaraps/promptless.git
+ md5sums = SKIP
+
+pkgname = promptless
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c990b46b4a0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dylan Araps <dylan.araps@gmail.com>
+pkgname=promptless
+_pkgname=promptless
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="A super fast and extremely minimal shell prompt."
+arch=('any')
+url="https://github.com/dylanaraps/${_pkgname}"
+license=('MIT')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=()
+optdepends=()
+makedepends=('git')
+source=("$pkgname::git+https://github.com/dylanaraps/promptless.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags --long | sed -r -e 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+}
+
+package() {
+ cd "$pkgname"
+ install -D -m755 promptless.sh "$pkgdir/usr/bin/promptless.sh"
+}
+
+post_install() {
+ echo
+ echo "add 'promptless.sh' to your .bashrc or equivalent."
+ echo
+}