summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWu Zhenyu2023-10-28 17:15:32 +0800
committerWu Zhenyu2023-10-28 17:15:32 +0800
commita04f6d515f235c70f592716a9d8937efdbc9218d (patch)
tree2d8bc40e31a3d1be435459ed8b6d8ad19d2460ba
parent7990a33642824fae15f5806fbd42b2a272b41e29 (diff)
downloadaur-pseudo-git.tar.gz
:memo: Add man pages
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17bcae5b3673..ce584919c61d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,6 +8,7 @@ pkgbase = pseudo-git
arch = arm
arch = aarch64
license = LGPL
+ depends = sqlite
source = git+https://git.yoctoproject.org/pseudo
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e8f3a18873a2..969907961307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
_pkgname=pseudo
pkgname=$_pkgname-git
-pkgrel=1
pkgver=r420.f9f1278
+pkgrel=1
pkgdesc="an analogue to sudo"
arch=(i686 x86_64 arm aarch64)
url=https://git.yoctoproject.org/$_pkgname
+depends=(sqlite)
license=(LGPL)
source=("git+$url")
sha256sums=(SKIP)
@@ -26,4 +27,5 @@ package() {
cd "$_pkgname" || return 1
make DESTDIR="$pkgdir" LIBDIR=/usr/lib install
+ install -Dm644 "$srcdir/$_pkgname"/*.1 -t "$pkgdir/usr/share/man/man1"
}