summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpiros Georgaras2024-05-06 17:40:19 +0300
committerSpiros Georgaras2024-05-06 17:40:19 +0300
commit96fcc6483c704798666f90097f5649f10c00d3c9 (patch)
tree81014ae26109076f16f8bfeeb35ed13084a77545
parentfd3a2824ccfa768d9d0a97944c13ae390de6612d (diff)
downloadaur-pyradio-git.tar.gz
version 0.9.3.5 - focring compliance with the XDG Base Directory Specification
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94cc6de4e24d..c341c9b03922 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pyradio-git
pkgdesc = Internet radio player for the command line
- pkgver = 0.9.3.1
+ pkgver = 0.9.3.5
pkgrel = 1
- url = http://www.coderholic.com/pyradio/
+ url = https://github.com/coderholic/pyradio
arch = any
license = MIT
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 514207d25145..80770f652999 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
# Contributor: aksr <aksr at t-com dot me>
pkgname=pyradio-git
-pkgver=0.9.3.1
+pkgver=0.9.3.5.r0.g4c299e2
pkgrel=1
pkgdesc="Internet radio player for the command line"
arch=('any')
-url="http://www.coderholic.com/pyradio/"
+url="https://github.com/coderholic/pyradio"
license=('MIT')
depends=('python-dnspython' 'python-requests' 'python-psutil' 'python-netifaces' 'python-rich' 'python-dateutil')
optdepends=('mplayer: as backend' 'mpv: as backend' 'vlc: as backend' 'mkvtoolnix-cli: fix mplayer recordings, add chapters to recordings')
@@ -21,8 +21,10 @@ sha256sums=('SKIP')
prepare() {
cd $pkgname
_descr="$(git describe --long --tags)"
- sed -i "s/git_description = ''/git_description = '$_descr'/" pyradio/config.py
- sed -i 's/distro = None/distro = Arch Linux (AUR)/' pyradio/config
+ sed -i -e "s/git_description = ''/git_description = '$_descr'/" pyradio/config.py
+ sed -i -e 's/distro = None/distro = Arch Linux (AUR)/' \
+ -e 's/xdg_compliant = False/xdg_compliant = True/' \
+ pyradio/config
git -C "${srcdir}/${pkgname}" clean -dfx
}