summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2023-04-23 14:58:49 +0200
committerPhilipp A2023-04-23 14:58:49 +0200
commitb628ff7f4afab579334d729e8b4fb3009c5d797a (patch)
treee13c3121df88407a70d0fc0dbbce5016486bd291
parente2b599804b985aa39a6877a163211d22a32a1c7f (diff)
downloadaur-python-anndata.tar.gz
v0.9.1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dae16f137b34..2c06a1a45444 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-anndata
pkgdesc = A data structure for rectangular numeric data and sample/variable annotations.
- pkgver = 0.8.0
- pkgrel = 2
+ pkgver = 0.9.1
+ pkgrel = 1
url = https://github.com/theislab/anndata
arch = any
license = BSD
@@ -15,7 +15,7 @@ pkgbase = python-anndata
depends = python-h5py
depends = python-natsort
depends = python-packaging
- source = https://files.pythonhosted.org/packages/source/a/anndata/anndata-0.8.0.tar.gz
- sha256sums = 94d2cc6f76c0317c0ac28564e3092b313b7ad19c737d66701961f3e620b9066e
+ source = https://files.pythonhosted.org/packages/source/a/anndata/anndata-0.9.1.tar.gz
+ sha256sums = 1f28f2c427e67b0b99bdd2b281717c92a12660dfd23e0694939b6e733f0eb2c4
pkgname = python-anndata
diff --git a/.gitignore b/.gitignore
index 7e480d700bee..6b535dcf8f80 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
/src/
/*.pkg.*
/*.tar.gz
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index 37df7c3f23f4..e0bfd1e36f56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_name=anndata
pkgname=python-$_name
-pkgver=0.8.0
-pkgrel=2
+pkgver=0.9.1
+pkgrel=1
pkgdesc='A data structure for rectangular numeric data and sample/variable annotations.'
arch=(any)
url="https://github.com/theislab/$_name"
@@ -11,11 +11,11 @@ license=(BSD)
depends=(python-pandas python-scipy python-h5py python-natsort python-packaging)
makedepends=(python-flit-core python-setuptools-scm python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('94d2cc6f76c0317c0ac28564e3092b313b7ad19c737d66701961f3e620b9066e')
+sha256sums=('1f28f2c427e67b0b99bdd2b281717c92a12660dfd23e0694939b6e733f0eb2c4')
build() {
cd "$_name-$pkgver"
- python -m build --wheel --no-isolation --skip-dependency-check # xlrd < 2 not available on arch
+ python -m build --wheel --no-isolation
}
package() {