summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2024-03-14 20:18:04 +0800
committerlilac2024-03-14 20:18:04 +0800
commit8c9f3f877f61e778e1f50eac8edcb1cc91f2dfcb (patch)
treedf59496ca02c05f4b6341866e1745b401a5924e6
parent48c7008e34be2f6dd19fe26273b078f0683e3df4 (diff)
downloadaur-python-fastprocess.tar.gz
[lilac] updated to 2.0.0-5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3f781ea7bb2..2814a1e9efc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-fastprocess
pkgdesc = A fast subprocess library
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 5
url = https://github.com/dstathis/fastprocess
arch = any
- license = LGPL
+ license = LGPL-3.0-or-later
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- source = https://github.com/dstathis/fastprocess/archive/2.0.0.tar.gz
+ makedepends = python-wheel
+ source = python-fastprocess-2.0.0.tar.gz::https://github.com/dstathis/fastprocess/archive/2.0.0.tar.gz
sha512sums = 194bcf0b1ee094a836df624514b8125712431ef57f01063e6cf799dd3cae3e45b1573756cd8c8eec03837632159a5cd99e0d0cbab864d0dea0ab9527eb4d6a1f
pkgname = python-fastprocess
-
diff --git a/PKGBUILD b/PKGBUILD
index 21d885fe823b..ede23ac78882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
pkgname=python-fastprocess
_pkgname=fastprocess
pkgver=2.0.0
-pkgrel=1
+pkgrel=5
pkgdesc='A fast subprocess library'
arch=('any')
url='https://github.com/dstathis/fastprocess'
-license=('LGPL')
+license=('LGPL-3.0-or-later')
makedepends=(
- 'python-setuptools'
+ python-build
+ python-installer
+ python-setuptools
+ python-wheel
)
-source=("https://github.com/dstathis/fastprocess/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dstathis/fastprocess/archive/${pkgver}.tar.gz")
sha512sums=('194bcf0b1ee094a836df624514b8125712431ef57f01063e6cf799dd3cae3e45b1573756cd8c8eec03837632159a5cd99e0d0cbab864d0dea0ab9527eb4d6a1f')
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}
# vim:set ts=2 sw=2 et: