summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-06 08:12:19 -0500
committerCarlos Aznarán Laos2023-05-06 08:12:19 -0500
commit00acb4e423ebcd73e1043de5980fe23ed56d90b5 (patch)
treec9e6e4100db8d10dd85be0a7d8aab366f0ff2ffe
parent699714bbc76506d6d77f1469e3cc42e22505b6f9 (diff)
downloadaur-python-imutils.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a5b05de9bc..9bab7d72dc17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,14 @@
pkgbase = python-imutils
pkgdesc = A series of convenience functions to make basic image processing asier with OpenCV
pkgver = 0.5.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jrosebr1/imutils
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-opencv
depends = hdf5
source = https://pypi.org/packages/source/i/imutils/imutils-0.5.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7f29f4a1a074..1ee6e389db08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,21 @@ _base=imutils
pkgname=python-${_base}
pkgdesc="A series of convenience functions to make basic image processing asier with OpenCV"
pkgver=0.5.4
-pkgrel=2
+pkgrel=3
arch=(any)
url="https://github.com/jrosebr1/${_base}"
license=(MIT)
depends=(python-opencv hdf5)
+makedepends=(python-build python-installer python-setuptools python-wheel)
source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
sha512sums=('50f9b43842cac55055a94d277fea958b8593bbc9b249878cc7e545368220667cb853d059c9ea412d034220c240343fe5e009e407554a10da958822d6e7e30728')
build() {
cd ${_base}-${pkgver}
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${_base}-${pkgver}
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
}