summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-06-04 16:59:59 -0500
committerCarlos Aznarán Laos2023-06-04 16:59:59 -0500
commit6b5b87832e520e5b0f7fcb5bc4585373c7fba391 (patch)
treed6cb0d5eb5225b5dabb86b9871d09a7f436f04bf
parent55ea9f071d4d40d0678abf8c064422e6e2e398b1 (diff)
downloadaur-python-pygmsh.tar.gz
Python 3.11 rebuild
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1357aecdc6c..3f77c2fd20e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-pygmsh
pkgdesc = Gmsh for Python
pkgver = 7.1.17
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/nschloe/pygmsh
arch = x86_64
license = GPL3
checkdepends = python-pytest-codeblocks
+ checkdepends = python-matplotlib
makedepends = python-build
makedepends = python-flit-core
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index b32083a4a68f..a800e7dee956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@ _base=pygmsh
pkgname=python-${_base}
pkgdesc="Gmsh for Python"
pkgver=7.1.17
-pkgrel=2
-arch=('x86_64')
+pkgrel=3
+arch=(x86_64)
url="https://github.com/nschloe/${_base}"
license=(GPL3)
depends=(python-meshio gmsh)
makedepends=(python-build python-flit-core python-installer)
-checkdepends=(python-pytest-codeblocks) # python-matplotlib
+checkdepends=(python-pytest-codeblocks python-matplotlib)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('f43716750d43c44121f06d7275540c0a6fb0fcb619b9475377b43b46c2e8f6c336e23b80a25383b617f6a0843ec86521699faae573aca01b1d4e12970cc72987')
@@ -22,17 +22,14 @@ check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
- MPLBACKEND=Agg PYTHONPATH="/usr/share/gmsh/api/python:${PYTHONPATH}" test-env/bin/python -m pytest --codeblocks -k 'not circle and not ellipsoid and not swiss_cheese'
+ MPLBACKEND=Agg PYTHONPATH="/usr/share/gmsh/api/python:${PYTHONPATH}" test-env/bin/python -m pytest \
+ --codeblocks \
+ -k 'not circle and not ellipsoid and not swiss_cheese'
}
package() {
- cd "${_base}-${pkgver}"
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
-
- # Symlink license file
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- ln -s "${site_packages}/${_base}-$pkgver.dist-info/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
echo 'Important note: for the python-gmsh module to be available you need to add export PYTHONPATH="$PYTHONPATH:/usr/share/gmsh/api/python" in ~/.bashrc, ~/.zshrc, etc. :-)'
}