summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-07 13:51:15 -0600
committerLuis Martinez2023-03-07 13:51:15 -0600
commitace8b9566c7a9554037617a728fd9b48b0eeaeed (patch)
tree07951979cd3e01881da89c93d801c8496f27944b
parenta222b402cfa7e35e55e3ac0bfe3e25bfab874c39 (diff)
downloadaur-python-pysonic.tar.gz
update to 1.0.0
-rw-r--r--.SRCINFO17
-rw-r--r--CHANGELOG.md62
-rw-r--r--PKGBUILD28
3 files changed, 88 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5b2a28b8517..9922ab5af81a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = python-pysonic
- pkgdesc = A python library to wrap the Subsonic REST API
- pkgver = 0.7.7
+ pkgdesc = Python library to wrap the Subsonic REST API
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/crustymonkey/py-sonic
arch = any
license = GPL3
- makedepends = python
- depends = python-setuptools
- provides = python-pysonic
- source = https://github.com/crustymonkey/py-sonic/archive/0.7.7.tar.gz
- sha256sums = 2de521d5c79d73025f32ac261ab581bdef1e100c00e7fd0d8992310af662d998
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ source = python-pysonic-1.0.0.tar.gz::https://files.pythonhosted.org/packages/source/p/py-sonic/py-sonic-1.0.0.tar.gz
+ sha256sums = f61a3417991fef8a42b0bba3c0bb7ea54f88931bbbd3f924f963fb9670fb0a21
pkgname = python-pysonic
-
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..db8f072cd0de
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,62 @@
+## 0.7.0
+
+* py-sonic should now python 2/3 compatible. Unfortunately, this adds the requirement of the "six" module for this compatibility. Please file a bug if you run into issues with either python 2 or 3.
+* Cut over to setuptools from disttools for pip requirement support
+
+## 0.6.2
+
+* Added an option to use GET requests, instead of the default POST requests
+
+## 0.6.1
+
+* Added `legacyAuth` option for pre-1.13.0 support
+
+## 0.6.0
+
+* Added API 1.14.0 support
+
+## 0.5.1
+
+* Added the ability to use a netrc file for credentials
+
+## 0.5.0
+
+* Added support for using credentials via a netrc file
+
+## 0.4.1
+
+* Fixed SSL handling issues
+
+## 0.4.0
+
+* Added missing 1.12.0 API items
+* Added 1.13.0 API items
+* All timestamps both passed in, and returned, should now be in **proper** unix time, which is seconds since the epoch, **not** milliseconds since the epoch
+
+## 0.3.5
+
+* allow for self-signed certs
+
+## 0.3.4
+
+* Add missing parameters to getAlbumList2 (thanks to basilfx)
+* Remove trailing whitespace (thanks to basilfx)
+
+## 0.3.3
+
+* Added support for API version 1.11.0
+* Added a couple of additions from API version 1.10.x that were previously
+ missed
+
+## 0.3.1
+
+* Incorporated unofficial API calls (beallio)
+
+## 0.2.1
+
+* Added a patch to force SSLv3 as some users were apparently having issues
+ with the 4.7 release of Subsonic and SSL. (thanks to orangepeelbeef)
+
+## 0.2.0
+
+* Added support for API version 1.8.0 (Subsonic verion 4.7)
diff --git a/PKGBUILD b/PKGBUILD
index 8818de0ffb39..61a088e7e781 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
-#Maintainer: Guillaume Dott <guillaume+github at dott dot fr>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Guillaume Dott <guillaume+github at dott dot fr>
pkgname=python-pysonic
-pkgver=0.7.7
+_pkg=py-sonic
+pkgver=1.0.0
pkgrel=1
-pkgdesc="A python library to wrap the Subsonic REST API"
+pkgdesc='Python library to wrap the Subsonic REST API'
arch=('any')
url="https://github.com/crustymonkey/py-sonic"
license=('GPL3')
-depends=(
- 'python-setuptools')
-makedepends=('python')
-provides=('python-pysonic')
-source=("https://github.com/crustymonkey/py-sonic/archive/${pkgver}.tar.gz")
-sha256sums=('2de521d5c79d73025f32ac261ab581bdef1e100c00e7fd0d8992310af662d998')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+changelog=CHANGELOG.md
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('f61a3417991fef8a42b0bba3c0bb7ea54f88931bbbd3f924f963fb9670fb0a21')
+
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/py-sonic-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
}