summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2021-01-10 19:28:06 +0100
committerGrey Christoforo2021-01-10 19:28:06 +0100
commit90a24b43f33db9d59d85db3c56294ecfee6fa65c (patch)
tree9397deb8cef8731025cbd063e44b9d4703c1c096
parent1180d5d7240fa4f58638c48fd9f8a65c372c533c (diff)
downloadaur-python-q2-types.tar.gz
bump version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0c572123fa0..0362cd6a877e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-q2-types
pkgdesc = Definitions of common QIIME 2 types.
- pkgver = 2020.11.0.dev0
+ pkgver = 2021.2.0.dev0
pkgrel = 1
url = https://qiime2.org
arch = x86_64
@@ -13,8 +13,8 @@ pkgbase = python-q2-types
depends = python-h5py
depends = python-pandas
depends = python-ijson
- source = https://github.com/qiime2/q2-types/archive/2020.11.0.dev0.tar.gz
- sha256sums = f597c68a6b6ef9dae36cfe1ae3dadbb5078ff7c845e4694847daf7e1562bae72
+ source = python-q2-types-2021.2.0.dev0.tar.gz::https://github.com/qiime2/q2-types/archive/2021.2.0.dev0.tar.gz
+ sha256sums = ec0cbd2cdc20ee2dd9922b5cf40c66d52a637a14982c74ee8d3f022053db994c
pkgname = python-q2-types
diff --git a/PKGBUILD b/PKGBUILD
index cb1fa1a844ba..6d02bed42168 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,34 @@
pkgname=python-q2-types
_pkgname=q2-types
-pkgver=2020.11.0.dev0
+pkgver=2021.2.0.dev0
pkgrel=1
pkgdesc="Definitions of common QIIME 2 types."
arch=('x86_64')
url="https://qiime2.org"
license=('BSD')
-depends=('python' 'python-qiime2' 'python-biom-format' 'python-scikit-bio' 'python-h5py' 'python-pandas' 'python-ijson')
+depends=(
+python
+python-qiime2
+python-biom-format
+python-scikit-bio
+python-h5py
+python-pandas
+python-ijson
+)
makedepends=('python-setuptools')
-source=("https://github.com/qiime2/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('f597c68a6b6ef9dae36cfe1ae3dadbb5078ff7c845e4694847daf7e1562bae72')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/qiime2/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('ec0cbd2cdc20ee2dd9922b5cf40c66d52a637a14982c74ee8d3f022053db994c')
build() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py build
}
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
package(){
cd "$srcdir/$_pkgname-$pkgver"