summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2019-11-24 22:02:49 +0100
committerMichel Zou2019-11-24 22:02:49 +0100
commitb3eee71b99c6c6e6129694b0b5c8fd07084b2dd0 (patch)
treeb41a3107cc376d94a7890296fa27d9a8aff161d6
downloadaur-python-stateutil.tar.gz
1.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab7f1c43789b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-stateutil
+ pkgdesc = A collection of state machine utilities
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://bitbucket.org/daycoder/stateutil
+ arch = any
+ license = custom:PSF
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.io/packages/source/s/stateutil/stateutil-1.4.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = python-stateutil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c0dcbb3312
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=python-stateutil
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="A collection of state machine utilities"
+arch=(any)
+url="https://bitbucket.org/daycoder/stateutil"
+license=('custom:PSF')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://pypi.io/packages/source/s/stateutil/stateutil-$pkgver.tar.gz")
+sha512sums=('SKIP')
+
+check() {
+ # Not included in release tarball
+ cd stateutil-$pkgver
+ # python test_stateutil.py
+}
+
+package() {
+ cd stateutil-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}