summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2018-01-12 10:35:00 -0500
committerXavierCLL2018-01-12 10:35:00 -0500
commit705135205fab96b41446d247da1cc313c13c54de (patch)
tree11df69cc22cd6c9a1005a0a18a3d4fe79ecb0a43
parent7c4e9751f5c68a61e3677c64580fc90722f548d5 (diff)
downloadaur-python2-deap.tar.gz
Updated version to 1.2.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7038ed6fb97e..8ed80e1c9192 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-deap
pkgdesc = Distributed Evolutionary Algorithms in Python
- pkgver = 1.0.2
+ pkgver = 1.2.2
pkgrel = 1
url = https://github.com/DEAP/deap
arch = any
@@ -10,8 +10,8 @@ pkgbase = python2-deap
optdepends = python2-numpy: for CMA-ES
optdepends = python2-matplotlib: for visualization
optdepends = python2-scoop: for computation distribution
- source = https://pypi.python.org/packages/source/d/deap/deap-1.0.2.post2.tar.gz
- md5sums = ccf5ed7562e4d6236c9416e3b5a9d941
+ source = https://github.com/DEAP/deap/archive/1.2.2.tar.gz
+ md5sums = 49a80a4033a6869a15cca24ea4982910
pkgname = python2-deap
diff --git a/PKGBUILD b/PKGBUILD
index 803e21af7d03..0fd2246a2beb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=python2-deap
-pkgver=1.0.2
+pkgver=1.2.2
pkgrel=1
pkgdesc="Distributed Evolutionary Algorithms in Python"
arch=('any')
@@ -7,11 +7,11 @@ url="https://github.com/DEAP/deap"
license=('LGPL')
depends=('python2' 'python2-pysqlite')
optdepends=("python2-numpy: for CMA-ES" "python2-matplotlib: for visualization" "python2-scoop: for computation distribution")
-source=("https://pypi.python.org/packages/source/d/deap/deap-$pkgver.post2.tar.gz")
-md5sums=('ccf5ed7562e4d6236c9416e3b5a9d941')
+source=("https://github.com/DEAP/deap/archive/$pkgver.tar.gz")
+md5sums=('49a80a4033a6869a15cca24ea4982910')
package() {
- cd "$srcdir/deap-$pkgver"
+ cd "deap-$pkgver"
find . -name '*.py' -exec sed -i -e '1 s/python\s*$/python2/' {} \;
python2 setup.py install --root="$pkgdir/" --optimize=1
}