summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErhan SAHIN2015-07-03 01:42:53 +0300
committerErhan SAHIN2015-07-03 01:42:53 +0300
commit2392ba0b33c27653f091e0d371fcf865be93324a (patch)
treeee8cd24166c08888973b69cacaade19696c1fe9c
downloadaur-python2-django-appconf-liberty.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..281e477683e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-django-appconf-liberty
+ pkgdesc = A helper class for handling configuration defaults of packaged Django apps gracefully.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/django-appconf
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ makedepends = python2-setuptools
+ source = https://pypi.python.org/packages/source/d/django-appconf/django-appconf-1.0.1.tar.gz
+ sha1sums = f25751fe513ae680b3016fef964d83c2da819932
+
+pkgname = python2-django-appconf-liberty
+ depends = python2-django-openstack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f395f621168
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Erhan SAHIN <erhan@ssahin.net>
+
+pkgname=("python2-django-appconf-liberty")
+pkgver="1.0.1"
+pkgrel="1"
+pkgdesc="A helper class for handling configuration defaults of packaged Django apps gracefully."
+arch=("i686" "x86_64")
+url="https://pypi.python.org/pypi/django-appconf"
+license=("BSD")
+makedepends=("python2" "python2-setuptools")
+source=("https://pypi.python.org/packages/source/d/django-appconf/django-appconf-$pkgver.tar.gz")
+sha1sums=('f25751fe513ae680b3016fef964d83c2da819932')
+
+build() {
+ cd "$srcdir/django-appconf-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ depends=("python2-django-openstack")
+
+ cd "$srcdir/django-appconf-$pkgver"
+ python2 setup.py install --prefix="/usr" --root="$pkgdir"
+}