summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2015-05-31 11:36:48 +0200
committerGeorg Schlisio2015-05-31 11:36:48 +0200
commit21ac04934821b14bc7c9132d4b8b094911bd3212 (patch)
tree58d1bbf2df13f6d6d90d377155b0027df8a51979
downloadaur-r-cran-wikibooks.tar.gz
0.2-1; port from aur3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ee0eb3cbfec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = r-cran-wikibooks
+ pkgdesc = collection of functions and datas used in the german WikiBook 'GNU R'
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://cran.r-project.org/web/packages/wikibooks/index.html
+ arch = any
+ license = GPL3
+ depends = r
+ source = http://cran.r-project.org/src/contrib/wikibooks_0.2.tar.gz
+ md5sums = e7e28894723f66fd83bdc551bc431390
+
+pkgname = r-cran-wikibooks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbb9e27e786c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+_cranname=wikibooks
+pkgname=r-cran-$_cranname
+pkgver=0.2
+pkgrel=1
+pkgdesc="collection of functions and datas used in the german WikiBook 'GNU R'"
+url="http://cran.r-project.org/web/packages/${_cranname}/index.html"
+arch=('any')
+license=('GPL3')
+depends=('r')
+source=("http://cran.r-project.org/src/contrib/${_cranname}_${pkgver}.tar.gz")
+md5sums=('e7e28894723f66fd83bdc551bc431390')
+
+build() {
+ mkdir -p ${pkgdir}/usr/lib/R/library
+ cd ${srcdir}
+ R CMD INSTALL ${_cranname} -l ${pkgdir}/usr/lib/R/library
+}