summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-05-08 18:04:48 +0000
committerBioArchLinuxBot2024-05-08 18:04:48 +0000
commit5b8834f858c0b06d2ed71d9e47f36880c9c6b2c7 (patch)
treedbe42d98788c4c6da810694d5d8ce47ac2420520
parent1044cf641ab8ec482c1422e11d772d92f5f8d4f5 (diff)
downloadaur-r-epitxdb.tar.gz
[lilac] updated to 1.16.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d3b58486e91..8b9517d13db0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = r-epitxdb
pkgdesc = Storing and accessing epitranscriptomic information using the AnnotationDbi interface
- pkgver = 1.14.1
+ pkgver = 1.16.0
pkgrel = 1
url = https://bioconductor.org/packages/EpiTxDb
arch = any
- license = Artistic2.0
- depends = r
+ license = Artistic-2.0
depends = r-annotationdbi
depends = r-biocfilecache
depends = r-biocgenerics
@@ -18,9 +17,11 @@ pkgbase = r-epitxdb
depends = r-httr
depends = r-iranges
depends = r-modstrings
+ depends = r-rex
depends = r-rsqlite
depends = r-s4vectors
depends = r-trnadbimport
+ depends = r-txdbmaker
depends = r-xml2
optdepends = r-annotationhub
optdepends = r-biocstyle
@@ -34,7 +35,8 @@ pkgbase = r-epitxdb
optdepends = r-rmarkdown
optdepends = r-testthat
optdepends = r-txdb.hsapiens.ucsc.hg38.knowngene
- source = https://bioconductor.org/packages/release/bioc/src/contrib/EpiTxDb_1.14.1.tar.gz
- sha256sums = ad425f358f3cd7b31efb8c29069b204bd9b83d90cf13638dd92f704826c78762
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/EpiTxDb_1.16.0.tar.gz
+ md5sums = 20e35a30fee32809fda75ba666f36a8c
+ b2sums = ba8bf305321b12954444d77c2f46b35b1bccfb6e5f7da515192c9dde0fcecee8b2f8055f6dc4b9dcec8ee29f4a9a4472b4a9d82867135c600832ca7e7fc66b5d
pkgname = r-epitxdb
diff --git a/PKGBUILD b/PKGBUILD
index 62d87cc33e85..4492701a93f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=EpiTxDb
-_pkgver=1.14.1
+_pkgver=1.16.0
pkgname=r-${_pkgname,,}
-pkgver=1.14.1
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Storing and accessing epitranscriptomic information using the AnnotationDbi interface'
-arch=('any')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('Artistic2.0')
+pkgdesc="Storing and accessing epitranscriptomic information using the AnnotationDbi interface"
+arch=(any)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('Artistic-2.0')
depends=(
- r
r-annotationdbi
r-biocfilecache
r-biocgenerics
@@ -23,9 +22,11 @@ depends=(
r-httr
r-iranges
r-modstrings
+ r-rex
r-rsqlite
r-s4vectors
r-trnadbimport
+ r-txdbmaker
r-xml2
)
optdepends=(
@@ -43,14 +44,15 @@ optdepends=(
r-txdb.hsapiens.ucsc.hg38.knowngene
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('ad425f358f3cd7b31efb8c29069b204bd9b83d90cf13638dd92f704826c78762')
+md5sums=('20e35a30fee32809fda75ba666f36a8c')
+b2sums=('ba8bf305321b12954444d77c2f46b35b1bccfb6e5f7da515192c9dde0fcecee8b2f8055f6dc4b9dcec8ee29f4a9a4472b4a9d82867135c600832ca7e7fc66b5d')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: