summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2024-05-04 00:03:18 +0000
committerBioArchLinuxBot2024-05-04 00:03:18 +0000
commit7020da02b976f10275e14949c913e336bbf5bf99 (patch)
tree7236a74d26b866908505f5f714e3e09cf18e60e4
parent0f684068bad7329c056fc335dea81f4b90b7ff04 (diff)
downloadaur-r-quasr.tar.gz
[lilac] updated to 1.44.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e272e10623..c6babb5d5a7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,13 @@
pkgbase = r-quasr
pkgdesc = Quantify and Annotate Short Reads in R
- pkgver = 1.42.1
+ pkgver = 1.44.0
pkgrel = 1
url = https://bioconductor.org/packages/QuasR
arch = x86_64
- license = GPL
- depends = r
+ license = GPL-2.0-only
+ makedepends = r-rhtslib
+ depends = bzip2
+ depends = curl
depends = r-annotationdbi
depends = r-biobase
depends = r-biocgenerics
@@ -18,11 +20,13 @@ pkgbase = r-quasr
depends = r-genomicranges
depends = r-iranges
depends = r-rbowtie
- depends = r-rhtslib
depends = r-rsamtools
depends = r-rtracklayer
depends = r-s4vectors
depends = r-shortread
+ depends = r-txdbmaker
+ depends = xz
+ depends = zlib
optdepends = r-biocstyle
optdepends = r-covr
optdepends = r-genomicalignments
@@ -31,7 +35,8 @@ pkgbase = r-quasr
optdepends = r-rhisat2
optdepends = r-rmarkdown
optdepends = r-testthat
- source = https://bioconductor.org/packages/release/bioc/src/contrib/QuasR_1.42.1.tar.gz
- sha256sums = d66ef1bbf95ae60bb5b7cf87dea6dae6adcc92229ef69984b1589073b7bc2519
+ source = https://bioconductor.org/packages/release/bioc/src/contrib/QuasR_1.44.0.tar.gz
+ md5sums = 9a98ddfa2e479bfe68cc9c8ec38fedd7
+ b2sums = c3c01e1b4dd242c737d5c1b8d9da74547d1ced56a82b1d7741848caee395a56897b8903955ff508787b5b2155161867026f9518c10d514051476adc00f0325c4
pkgname = r-quasr
diff --git a/PKGBUILD b/PKGBUILD
index c0d07fa3894e..1696e6675c5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
-# system requirements: GNU make
# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
_pkgname=QuasR
-_pkgver=1.42.1
+_pkgver=1.44.0
pkgname=r-${_pkgname,,}
-pkgver=1.42.1
+pkgver=${_pkgver//-/.}
pkgrel=1
-pkgdesc='Quantify and Annotate Short Reads in R'
-arch=('x86_64')
-url="https://bioconductor.org/packages/${_pkgname}"
-license=('GPL')
+pkgdesc="Quantify and Annotate Short Reads in R"
+arch=(x86_64)
+url="https://bioconductor.org/packages/$_pkgname"
+license=('GPL-2.0-only')
depends=(
- r
+ bzip2
+ curl
r-annotationdbi
r-biobase
r-biocgenerics
@@ -24,11 +24,16 @@ depends=(
r-genomicranges
r-iranges
r-rbowtie
- r-rhtslib
r-rsamtools
r-rtracklayer
r-s4vectors
r-shortread
+ r-txdbmaker
+ xz
+ zlib
+)
+makedepends=(
+ r-rhtslib
)
optdepends=(
r-biocstyle
@@ -41,14 +46,15 @@ optdepends=(
r-testthat
)
source=("https://bioconductor.org/packages/release/bioc/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
-sha256sums=('d66ef1bbf95ae60bb5b7cf87dea6dae6adcc92229ef69984b1589073b7bc2519')
+md5sums=('9a98ddfa2e479bfe68cc9c8ec38fedd7')
+b2sums=('c3c01e1b4dd242c737d5c1b8d9da74547d1ced56a82b1d7741848caee395a56897b8903955ff508787b5b2155161867026f9518c10d514051476adc00f0325c4')
build() {
- R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+ mkdir build
+ R CMD INSTALL -l build "$_pkgname"
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}
-# vim:set ts=2 sw=2 et: