summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Büchau2022-01-04 12:28:46 +0100
committerYann Büchau2022-01-04 12:32:35 +0100
commitd5fc3f330136aea16d06435541a2feb42c66568d (patch)
treeaef71fc58bc6d2021388f43e3d942462442409d4
parent80aa1b343c778b2a4dabf7d36e8e4c399a828167 (diff)
downloadaur-d5fc3f330136aea16d06435541a2feb42c66568d.tar.gz
Stop build with warning if wrong Java version is used
-rw-r--r--PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68556e4dec66..14b68b84e351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,6 +40,18 @@ pkgver() {
}
prepare () {
+ if test "`archlinux-java get`" != "java-8-openjdk";then
+ cat<<EOT
+ Your default Java version is set to `archlinux-java get`, not java-8-openjdk!
+
+ Fix it with:
+
+ archlinux-java set java-8-openjdk
+
+EOT
+ exit 1
+ fi
+
cd ${srcdir}/$_gitname
# Patching SOCI
# patch -p1 < ${srcdir}/soci.patch