summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2022-01-01 22:59:08 +0300
committerOrhun Parmaksız2022-01-01 22:59:08 +0300
commit2c762d896518ab4125257b4239342b065074dc1d (patch)
treef503b0c99fbaf6c92f3b6869a47801ab1616c5d8
downloadaur-rustfilt.tar.gz
Initial upload: rustfilt 0.2.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD35
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a7b3db494192
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rustfilt
+ pkgdesc = Demangle Rust symbol names
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = https://github.com/luser/rustfilt
+ arch = x86_64
+ license = Apache
+ makedepends = rust
+ depends = gcc-libs
+ source = rustfilt-0.2.1.tar.gz::https://github.com/luser/rustfilt/archive/0.2.1.tar.gz
+ sha256sums = f09bb822c8b22c4c89bf63cc64f8f85a053e1850a70cad4b7308e00871527496
+
+pkgname = rustfilt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2dae55620d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=rustfilt
+pkgrel=1
+pkgver=0.2.1
+pkgdesc="Demangle Rust symbol names"
+arch=('x86_64')
+url="https://github.com/luser/rustfilt"
+license=('Apache')
+depends=('gcc-libs')
+makedepends=('rust')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('f09bb822c8b22c4c89bf63cc64f8f85a053e1850a70cad4b7308e00871527496')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}