summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2021-07-19 11:16:08 +0200
committerGFdevelop2021-07-19 11:16:08 +0200
commit84c8825f6dedbbc96c28ac53839c2c88928625c7 (patch)
tree6c9f1dcefe57560d60ad0570b5b5f6952c3b85bb
parent411a182fab457c4668bbe896e985e0855eecc52b (diff)
downloadaur-s2argv-execs-git.tar.gz
update url and build with cmake
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b1382fa50d5..8c0e232c06f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = s2argv-execs-git
pkgdesc = s2argv converts a command string into an argv array for execv*, execs is like execv taking a string instead of an argv
- pkgver = r37.aa3c3d6
- pkgrel = 2
- url = https://github.com/rd235/s2argv-execs
+ pkgver = r38.2f3f79c
+ pkgrel = 1
+ url = https://github.com/virtualsquare/s2argv-execs
arch = any
+ groups = virtualsquare
license = LGPL
makedepends = git
+ makedepends = cmake
depends = glibc
provides = s2argv-execs
conflicts = s2argv-execs
- source = git+https://github.com/rd235/s2argv-execs.git
+ source = git+https://github.com/virtualsquare/s2argv-execs.git
md5sums = SKIP
pkgname = s2argv-execs-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2c87f13d7a57..09cf7182c426 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,15 @@
_pkgname="s2argv-execs"
pkgname="$_pkgname-git"
-pkgver=r37.aa3c3d6
-pkgrel=2
+pkgver=r38.2f3f79c
+pkgrel=1
pkgdesc="s2argv converts a command string into an argv array for execv*, execs is like execv taking a string instead of an argv"
arch=('any')
-url="https://github.com/rd235/$_pkgname"
+url="https://github.com/virtualsquare/$_pkgname"
license=('LGPL')
+groups=('virtualsquare')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'cmake')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+$url.git")
@@ -24,12 +25,13 @@ pkgver() {
build() {
cd "$_pkgname"
- autoreconf -if
- ./configure --prefix="/usr"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd "$_pkgname"
+ cd "$_pkgname"/build
make DESTDIR="$pkgdir/" install
}