summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302022-12-31 16:59:07 +0100
committerM0Rf302022-12-31 16:59:07 +0100
commit57179f1054d987058a1011875787191243fda33c (patch)
treede2fcb964bcf7b2a1cba33fdf37aa78ceaae2ddf
parentd23a2a461a8817f6c532223879e4154a68b8e960 (diff)
downloadaur-soulseekqt.tar.gz
soulseekqt: 20221224
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD76
-rw-r--r--selinux-mock.c5
-rw-r--r--soulseekqt.desktop9
-rw-r--r--soulseekqt.sh2
5 files changed, 58 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddd57a5d18ab..29ba29590806 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = soulseekqt
pkgdesc = A desktop client for the Soulseek peer-to-peer file sharing network
- pkgver = 20180130
- pkgrel = 13
+ pkgver = 20221224
+ pkgrel = 1
url = http://www.soulseekqt.net/news/
arch = x86_64
license = CUSTOM
depends = freetype2
options = !strip
- source = https://www.slsknet.org/SoulseekQt/Linux/SoulseekQt-2018-1-30-64bit-appimage.tgz
- source = selinux-mock.c
- source = soulseekqt.sh
- source = soulseekqt.desktop
- md5sums = 1d98331893bc9b9d45ba34f6523353ab
- md5sums = 4ed42be654289fc9cd7f4181c363f745
- md5sums = eb61e1e5510c95c8c9a93f46a5541597
- md5sums = 2544611108889c2c4c7a9084672f4d32
+ source = https://github.com/M0Rf30/soulseekqt-binaries/releases/download/20221224/SoulseekQt-2022-12-24-64bit.AppImage.tgz
+ source = https://github.com/M0Rf30/soulseekqt-binaries/raw/main/hacks/selinux-mock.c
+ source = https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/soulseekqt.desktop
+ source = https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/soulseekqt.png
+ source = https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/soulseekqt.sh
+ sha256sums = 86e1f5501e614cb12ee32242daff5338d1d45e3a0fd9a882d32d517b68eb1849
+ sha256sums = dabd228cf296dc4dd9462a21d16cc6cbfc77ee2abfcae3297ec783e6184dc9f4
+ sha256sums = ecb2e829138c9d8373b5ba4e042e01ef34b3701ddc306f753acf894fff4047bf
+ sha256sums = 5097f36ea49f1a61cbb975507de99dc7e768d0377e3736b431fee47f13a45e1c
+ sha256sums = 8d74a05712838f5250496d7538e8354a716e2ec4138a8bc9948886a85ef1c9cb
pkgname = soulseekqt
-
diff --git a/PKGBUILD b/PKGBUILD
index 5b00ac4dd4e2..e1b881ccecb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,47 +4,63 @@
# Contributor: farnsworth517
pkgname=soulseekqt
-pkgver=20180130
-_pkgver=2018-1-30
-pkgrel=13
+pkgver=20221224
+_pkgver=2022-12-24
+_appimage="SoulseekQt-${_pkgver}-64bit.AppImage"
+pkgrel=1
pkgdesc="A desktop client for the Soulseek peer-to-peer file sharing network"
arch=('x86_64')
url="http://www.soulseekqt.net/news/"
license=('CUSTOM')
depends=('freetype2')
-source=("https://www.slsknet.org/SoulseekQt/Linux/SoulseekQt-${_pkgver}-64bit-appimage.tgz"
- selinux-mock.c
- soulseekqt.sh
- $pkgname.desktop
+
+source=(
+ "https://github.com/M0Rf30/soulseekqt-binaries/releases/download/${pkgver}/${_appimage}.tgz"
+ "https://github.com/M0Rf30/soulseekqt-binaries/raw/main/hacks/selinux-mock.c"
+ "https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/${pkgname}.desktop"
+ "https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/${pkgname}.png"
+ "https://github.com/M0Rf30/soulseekqt-binaries/raw/main/desktop/${pkgname}.sh"
)
options=("!strip")
prepare() {
- cd "$srcdir"
- msg2 "Extraction..."
- ./"SoulseekQt-${_pkgver}-64bit.AppImage" --appimage-extract
-
- msg2 "Compiling libselinux.so.1 fakelib"
- gcc -s -shared -o libselinux.so.1 -Wl,-soname,libselinux.so.1 selinux-mock.c
+ cd "$srcdir"
+ msg2 "Extraction..."
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+
+ msg2 "Compiling libselinux.so.1 fakelib"
+ gcc -s -shared -o libselinux.so.1 -Wl,-soname,libselinux.so.1 selinux-mock.c
}
package() {
- cd "$srcdir"
- mkdir -p "$pkgdir/opt/"
- cp -r squashfs-root "$pkgdir/opt/$pkgname"
- install -vDm755 soulseekqt.sh "$pkgdir/usr/bin/$pkgname"
- install -vDm755 libselinux.so.1 "$pkgdir/opt/soulseekqt/lib/libselinux.so.1"
- install -vDm644 squashfs-root/soulseek.png "$pkgdir/usr/share/pixmaps/soulseek.png"
- install -vDm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- msg2 "Cleanup"
- chmod 755 -R "$pkgdir/opt/$pkgname"
- # This fix context menu on right click in search results
- rm "$pkgdir/opt/$pkgname/lib/libfreetype.so.6"
- rm -rf "$pkgdir"/opt/soulseekqt/{AppRun,default.desktop,soulseek.png,*.AppImage}
+ cd "$srcdir"
+
+ mkdir -p "${pkgdir}/opt/"
+ cp -r squashfs-root "${pkgdir}/opt/$pkgname"
+
+ # workaround for selinux
+ install -Dm755 libselinux.so.1 \
+ "${pkgdir}/opt/soulseekqt/lib/libselinux.so.1"
+
+ # Desktop resources
+ install -Dm755 "${pkgname}.sh" \
+ "${pkgdir}/usr/bin/$pkgname"
+ install -Dm644 "${pkgname}.png" \
+ "${pkgdir}/usr/share/pixmaps/soulseek.png"
+ install -Dm644 "$pkgname.desktop" \
+ "${pkgdir}/usr/share/applications/$pkgname.desktop"
+
+ msg2 "Cleanup"
+
+ chmod 755 -R "${pkgdir}/opt/$pkgname"
+
+ # This fix context menu on right click in search results
+ rm -rf "${pkgdir}"/opt/soulseekqt/{AppRun,default.desktop,soulseek.png,*.AppImage}
}
-md5sums=('1d98331893bc9b9d45ba34f6523353ab'
- '4ed42be654289fc9cd7f4181c363f745'
- 'eb61e1e5510c95c8c9a93f46a5541597'
- '2544611108889c2c4c7a9084672f4d32')
+sha256sums=('86e1f5501e614cb12ee32242daff5338d1d45e3a0fd9a882d32d517b68eb1849'
+ 'dabd228cf296dc4dd9462a21d16cc6cbfc77ee2abfcae3297ec783e6184dc9f4'
+ 'ecb2e829138c9d8373b5ba4e042e01ef34b3701ddc306f753acf894fff4047bf'
+ '5097f36ea49f1a61cbb975507de99dc7e768d0377e3736b431fee47f13a45e1c'
+ '8d74a05712838f5250496d7538e8354a716e2ec4138a8bc9948886a85ef1c9cb')
diff --git a/selinux-mock.c b/selinux-mock.c
deleted file mode 100644
index 574d994d70e1..000000000000
--- a/selinux-mock.c
+++ /dev/null
@@ -1,5 +0,0 @@
-extern int is_selinux_enabled(void)
-{
- /* always return 0; this way we don't trigger any SELINUX calls */
- return 0;
-}
diff --git a/soulseekqt.desktop b/soulseekqt.desktop
deleted file mode 100644
index 8f837f9e3dfb..000000000000
--- a/soulseekqt.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=SoulSeekQT
-Exec=soulseekqt
-Icon=soulseek
-Terminal=false
-Type=Application
-Categories=Network;P2P;
-Comment=Soulseek music-sharing client
-StartupWMClass=soulseekqt.AppImage
diff --git a/soulseekqt.sh b/soulseekqt.sh
deleted file mode 100644
index 0e2cb8e3d24d..000000000000
--- a/soulseekqt.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/bash
-exec /opt/soulseekqt/SoulseekQt