summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2016-08-28 15:12:31 +0430
committerBehnam Momeni2016-08-28 15:12:31 +0430
commit9bf8a1b417fadacfddd07df53c75d480cc15d130 (patch)
tree70693d54e19d4bf952d10837604bf535b42a1e78
parentf2039a5e4b75b92b50bcc04265de428a9b092804 (diff)
downloadaur-9bf8a1b417fadacfddd07df53c75d480cc15d130.tar.gz
Creating extras_media and tools_texts2paths subpackages
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD48
-rw-r--r--texts2paths.patch20
3 files changed, 80 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 58b91f8b58fd..3a1d9fdb1495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Aug 28 10:39:42 UTC 2016
pkgbase = sozi
pkgdesc = A zooming presentation based on SVG, using JavaScript
pkgver = 16.02
- pkgrel = 4
+ pkgrel = 5
url = http://sozi.baierouge.fr/
arch = i686
arch = x86_64
@@ -11,13 +13,6 @@ pkgbase = sozi
makedepends = nodejs-grunt-cli
makedepends = jq
makedepends = semver
- depends = gconf
- depends = libnotify
- depends = alsa-lib
- depends = nss
- depends = gtk2
- depends = libxtst
- optdepends = inkscape: for editing the original SVG document (any SVG editor can be used)
noextract = fontawesome-v4.2.0.tar.gz
noextract = notifyjs-v0.3.4.tar.gz
noextract = jquery-v2.1.4.tar.gz
@@ -617,6 +612,7 @@ pkgbase = sozi
options = !strip
source = https://github.com/senshu/Sozi/archive/16.02-fix344.tar.gz
source = http://www.1001freefonts.com/d/5854/droid_sans.zip
+ source = texts2paths.patch
source = fontawesome-v4.2.0.tar.gz::https://github.com/FortAwesome/Font-Awesome/archive/v4.2.0.tar.gz
source = notifyjs-v0.3.4.tar.gz::https://github.com/jpillora/notifyjs/archive/0.3.4.tar.gz
source = jquery-v2.1.4.tar.gz::https://github.com/jquery/jquery/archive/2.1.4.tar.gz
@@ -1215,6 +1211,7 @@ pkgbase = sozi
source = https://registry.npmjs.org/zip-stream/-/zip-stream-0.5.2.tgz
sha1sums = 564a162628d6d179fd6785dec4d0e38e863b0e5d
sha1sums = 265b6cc7b7cea7bcfb74eec52bc9c0e44f039740
+ sha1sums = ebaf4c68d77391a701b3acfc21282eb78d8077fd
sha1sums = bc4b6e3849e9bc83e769b3c34f1fde1de22154bf
sha1sums = 11c3ca612c1d9a4f5043594e0b5da1d82e29425c
sha1sums = 79543e31819aa6e126f08e89750da8892c024181
@@ -1821,4 +1818,22 @@ pkgbase = sozi
sha1sums_x86_64 = af5bc341b95f50e94089e7fbb6535b6f6a919799
pkgname = sozi
+ depends = gconf
+ depends = libnotify
+ depends = alsa-lib
+ depends = nss
+ depends = gtk2
+ depends = libxtst
+ optdepends = inkscape: for editing the original SVG document (any SVG editor can be used)
+ optdepends = sozi-tools_texts2paths: for converting Text objects to Path objects
+ optdepends = sozi-extras_media: for Inkscape audio/video extensions
+
+pkgname = sozi-tools_texts2paths
+ pkgdesc = An script for converting Text objects of a SVG to Path objects
+ depends = python2-lxml
+ depends = inkscape
+
+pkgname = sozi-extras_media
+ pkgdesc = An Inkscape extension for adding audio/video elements
+ depends = inkscape
diff --git a/PKGBUILD b/PKGBUILD
index 2726078a77c7..fe0fbe5a967d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,16 @@
# Contributor: Guido <qqqqqqqqq9 at web dot de>
# Contributor: Emmanuel Gil Peyrot <linkmauve at linkmauve dot fr>
-pkgname="sozi"
+pkgbase='sozi'
+pkgname=('sozi'
+ 'sozi-tools_texts2paths'
+ 'sozi-extras_media')
pkgver=16.02
# the build version is obtained from [here](https://github.com/senshu/Sozi/releases)
_buildver=16.02.141048
_pkgverpostfix="-fix344" # this is required because the pkgver cannot contain hyphen
-pkgrel=4
+pkgrel=5
pkgdesc="A zooming presentation based on SVG, using JavaScript"
url="http://sozi.baierouge.fr/"
@@ -16,17 +19,15 @@ url="http://sozi.baierouge.fr/"
arch=('i686' 'x86_64')
license=('custom:MPL2.0')
-depends=("gconf" "libnotify" "alsa-lib" "nss" "gtk2" "libxtst")
-optdepends=(
- 'inkscape: for editing the original SVG document (any SVG editor can be used)'
-)
makedepends=('npm' 'bower' 'nodejs-grunt-cli'
'jq' 'semver')
source=("https://github.com/senshu/Sozi/archive/${pkgver}${_pkgverpostfix}.tar.gz"
- "http://www.1001freefonts.com/d/5854/droid_sans.zip")
+ "http://www.1001freefonts.com/d/5854/droid_sans.zip"
+ "texts2paths.patch")
sha1sums=('564a162628d6d179fd6785dec4d0e38e863b0e5d'
- '265b6cc7b7cea7bcfb74eec52bc9c0e44f039740')
+ '265b6cc7b7cea7bcfb74eec52bc9c0e44f039740'
+ 'ebaf4c68d77391a701b3acfc21282eb78d8077fd')
source_i686=('http://dl.nwjs.io/v0.12.3/nwjs-v0.12.3-linux-ia32.tar.gz'
'buildConfig-i686.js')
@@ -57,6 +58,8 @@ prepare() {
cp -a -l "${srcdir}/nwjs-v${_nwjsver}-linux-ia32" "cache/${_nwjsver}/linux32"
cp "${srcdir}/buildConfig-i686.js" "buildConfig.js"
fi
+
+ patch -p1 < "${srcdir}/texts2paths.patch"
}
bestmatch() {
@@ -166,7 +169,14 @@ build() {
grunt --verbose
}
-package() {
+package_sozi() {
+ depends=("gconf" "libnotify" "alsa-lib" "nss" "gtk2" "libxtst")
+ optdepends=(
+ 'inkscape: for editing the original SVG document (any SVG editor can be used)'
+ 'sozi-tools_texts2paths: for converting Text objects to Path objects'
+ 'sozi-extras_media: for Inkscape audio/video extensions'
+ )
+
if [[ $CARCH == "x86_64" ]]; then
cd "${srcdir}/Sozi-${pkgver}${_pkgverpostfix}/build/Sozi/Sozi-${_buildver}-linux64/"
else
@@ -180,13 +190,29 @@ package() {
ln -s "/opt/sozi-${pkgver}${_pkgverpostfix}/Sozi" sozi
cd "${srcdir}/Sozi-${pkgver}${_pkgverpostfix}/"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/sozi/MPL2.0"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/MPL2.0"
#TODO: Create a .desktop file too
}
-#TODO: Create other subpackages from "tools" and "extras" folders
+package_sozi-tools_texts2paths() {
+ pkgdesc="An script for converting Text objects of a SVG to Path objects"
+ depends=("python2-lxml" "inkscape")
+ cd "${srcdir}/Sozi-${pkgver}${_pkgverpostfix}/"
+ install -D -m755 tools/texts2paths/texts2paths.py "${pkgdir}/usr/bin/texts2paths.py"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/MPL2.0"
+}
+
+package_sozi-extras_media() {
+ pkgdesc="An Inkscape extension for adding audio/video elements"
+ depends=("inkscape")
+
+ cd "${srcdir}/Sozi-${pkgver}${_pkgverpostfix}/"
+ install -D -m644 extras/media/sozi_extras_media.inx "${pkgdir}/usr/share/inkscape/extensions/sozi_extras_media.inx"
+ install -D -m755 extras/media/sozi_extras_media.py "${pkgdir}/usr/share/inkscape/extensions/sozi_extras_media.py"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/MPL2.0"
+}
# bower dependencies:
source+=(
diff --git a/texts2paths.patch b/texts2paths.patch
new file mode 100644
index 000000000000..3827b333863b
--- /dev/null
+++ b/texts2paths.patch
@@ -0,0 +1,20 @@
+diff -ruN sozi-org/tools/texts2paths/texts2paths.py sozi-new/tools/texts2paths/texts2paths.py
+--- sozi-org/tools/texts2paths/texts2paths.py 2016-08-28 14:04:40.190289088 +0430
++++ sozi-new/tools/texts2paths/texts2paths.py 2016-08-28 14:08:39.806966462 +0430
+@@ -7,6 +7,7 @@
+ from optparse import OptionParser
+ from lxml import etree
+ import subprocess, shutil, sys
++import os
+
+ if __name__ == '__main__':
+ option_parser = OptionParser()
+@@ -44,6 +45,7 @@
+ command = ["inkscape"]
+ for t in texts:
+ command += ["--verb=EditDeselect", "--select=" + t.get("id"), "--verb=ObjectToPath"]
+- command += ["--verb=FileSave", "--verb=FileClose", output_file_name]
++ command += ["--verb=FileSave", "--verb=FileClose",
++ "--verb=FileQuit", output_file_name]
+
+ subprocess.call(command)