summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Theodorou2023-07-14 10:46:22 +0200
committerAngelo Theodorou2023-07-14 10:46:22 +0200
commit1b13f7990099a390c67896788fd9141674574e12 (patch)
tree71d1f13adeae5065944e4551efc62999637220c9
parentae97d5e58f56753eb65c0bbdee9ab679ae97ae99 (diff)
downloadaur-spookyghost-git.tar.gz
Remove prepare pass and add repos to source array
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 20 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a506a329c9e6..181e5d921f42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spookyghost-git
pkgdesc = A procedural sprite animation tool made with the nCine
- pkgver = r71.d3660bf
+ pkgver = r75.837135d
pkgrel = 1
url = https://encelo.itch.io/spookyghost
arch = i686
@@ -17,6 +17,12 @@ pkgbase = spookyghost-git
conflicts = spookyghost
options = !strip
source = git+https://github.com/SpookyGhost2D/SpookyGhost
+ source = git+https://github.com/nCine/nCine
+ source = git+https://github.com/nCine/nCine-data
+ source = git+https://github.com/SpookyGhost2D/SpookyGhost-data
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = spookyghost-git
diff --git a/PKGBUILD b/PKGBUILD
index 6d694caa5710..00f4abbcbc0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Angelo Theodorou <encelo@gmail.com>
pkgname=spookyghost-git
-pkgver=r71.d3660bf
+pkgver=r75.837135d
pkgrel=1
pkgdesc="A procedural sprite animation tool made with the nCine"
arch=('i686' 'x86_64')
@@ -12,8 +12,18 @@ makedepends=('git' 'cmake')
conflicts=('spookyghost')
provides=('spookyghost')
options=(!strip)
-source=('git+https://github.com/SpookyGhost2D/SpookyGhost')
-md5sums=('SKIP')
+source=(
+ 'git+https://github.com/SpookyGhost2D/SpookyGhost'
+ 'git+https://github.com/nCine/nCine'
+ 'git+https://github.com/nCine/nCine-data'
+ 'git+https://github.com/SpookyGhost2D/SpookyGhost-data'
+)
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
cd "$srcdir/SpookyGhost"
@@ -23,12 +33,6 @@ pkgver() {
)
}
-prepare() {
- git clone https://github.com/nCine/nCine || git -C nCine pull
- git clone https://github.com/nCine/nCine-data || git -C nCine-data pull
- git clone https://github.com/SpookyGhost2D/SpookyGhost-data || git -C SpookyGhost-data pull
-}
-
build() {
cmake -S nCine -B nCine-build\
-DCMAKE_BUILD_TYPE=Release\