summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorblue2024-02-04 14:03:13 -0300
committerblue2024-02-04 14:03:13 -0300
commitd04888957cf4b13b0c8762ece1a19d85e0d33372 (patch)
treee6b2af3b88ce9875b58dd43201ee6e334be929b0
parentd21486670990dc7d61d2fc8226ced489f174db1f (diff)
downloadaur-squawk.tar.gz
Refactoring and tray icon
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33e08a3fc5a3..46c3c1b4a339 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = squawk
pkgdesc = An XMPP desktop messenger, written on pure c++ (qt)
- pkgver = 0.2.2
+ pkgver = 0.2.3
pkgrel = 1
url = https://git.macaw.me/blue/squawk
arch = i686
@@ -12,13 +12,13 @@ pkgbase = squawk
makedepends = boost
depends = hicolor-icon-theme
depends = desktop-file-utils
- depends = lmdb
- depends = qxmpp>=1.1.0
- optdepends = kwallet: secure password storage (requires rebuild)
- optdepends = kconfig: system themes support (requires rebuild)
- optdepends = kconfigwidgets: system themes support (requires rebuild)
- optdepends = kio: better show in folder action (requires rebuild)
- source = squawk-0.2.2.tar.gz::https://git.macaw.me/attachments/808a59b3-1759-462d-83f6-81d08dd45377
- sha256sums = e4fa2174a3ba95159cc3b0bac3f00550c9e0ce971c55334e2662696a4543fc7e
+ depends = lmdbal
+ depends = qxmpp-qt5
+ optdepends = kwallet5: secure password storage (requires rebuild)
+ optdepends = kconfig5: system themes support (requires rebuild)
+ optdepends = kconfigwidgets5: system themes support (requires rebuild)
+ optdepends = kio5: better show in folder action (requires rebuild)
+ source = squawk-0.2.3.tar.gz::https://git.macaw.me/blue/squawk/archive/0.2.3.tar.gz
+ sha256sums = 4c48aaa59cf7744c931f446ca32eb9df3575583029951fd3f48a18e0eb3530d3
pkgname = squawk
diff --git a/PKGBUILD b/PKGBUILD
index 45502375e0e1..fae3b2ad3af2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Yury Gubich <blue@macaw.me>
pkgname=squawk
-pkgver=0.2.2
+pkgver=0.2.3
pkgrel=1
pkgdesc="An XMPP desktop messenger, written on pure c++ (qt)"
arch=('i686' 'x86_64')
url="https://git.macaw.me/blue/squawk"
license=('GPL3')
-depends=('hicolor-icon-theme' 'desktop-file-utils' 'lmdb' 'qxmpp>=1.1.0')
+depends=('hicolor-icon-theme' 'desktop-file-utils' 'lmdbal' 'qxmpp-qt5')
makedepends=('cmake>=3.3' 'imagemagick' 'qt5-tools' 'boost')
-optdepends=('kwallet: secure password storage (requires rebuild)'
- 'kconfig: system themes support (requires rebuild)'
- 'kconfigwidgets: system themes support (requires rebuild)'
- 'kio: better show in folder action (requires rebuild)')
+optdepends=('kwallet5: secure password storage (requires rebuild)'
+ 'kconfig5: system themes support (requires rebuild)'
+ 'kconfigwidgets5: system themes support (requires rebuild)'
+ 'kio5: better show in folder action (requires rebuild)')
-source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/attachments/808a59b3-1759-462d-83f6-81d08dd45377")
-sha256sums=('e4fa2174a3ba95159cc3b0bac3f00550c9e0ce971c55334e2662696a4543fc7e')
+source=("$pkgname-$pkgver.tar.gz::https://git.macaw.me/blue/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('4c48aaa59cf7744c931f446ca32eb9df3575583029951fd3f48a18e0eb3530d3')
build() {
cd "$srcdir/squawk"
cmake . -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release
- cmake --build . -j $nproc
+ cmake --build .
}
package() {
cd "$srcdir/squawk"
- DESTDIR="$pkgdir/" cmake --build . --target install
+ DESTDIR="$pkgdir/" cmake --install .
}