summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2022-08-13 15:40:32 +0900
committerXuanrui Qi2022-08-13 15:40:32 +0900
commit2140d8439cf3c6f1f46172531129145ced023656 (patch)
tree48753b0a4e903027ab4802f8cc4c51a8696cb65d
parente77fb10d5976ae1274f7a27f7b5dcd76927139e0 (diff)
downloadaur-ssrmint-git.tar.gz
License fix
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--license.patch13
3 files changed, 12 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c41752b4f0ea..b1992ea89b31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = ssrmint-git
pkgdesc = Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect
- pkgver = r13.fa1f7ab
- pkgrel = 5
+ pkgver = r19.658e636
+ pkgrel = 6
url = https://github.com/affeldt-aist/ssrmint
arch = any
license = BSD
makedepends = git
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-pygments
source = ssrmint-git::git+https://github.com/affeldt-aist/ssrmint
- source = license.patch
sha256sums = SKIP
- sha256sums = 6fa40b2b50c0cd2e513b2b9438a6d41e466a6012e7ac6d97f5ec578d44dfef5c
pkgname = ssrmint-git
diff --git a/PKGBUILD b/PKGBUILD
index f0adbf43efa9..f6bf5361ceb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
pkgname=ssrmint-git
-pkgver=r13.fa1f7ab
-pkgrel=5
+pkgver=r19.658e636
+pkgrel=6
pkgdesc="Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect"
arch=('any')
url="https://github.com/affeldt-aist/ssrmint"
license=('BSD')
depends=('python' 'python-pygments')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
optdepends=()
conflicts=()
-source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint"
- "license.patch")
-sha256sums=('SKIP'
- '6fa40b2b50c0cd2e513b2b9438a6d41e466a6012e7ac6d97f5ec578d44dfef5c')
+source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -22,13 +20,12 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
- patch -p1 < ../license.patch
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$srcdir/$pkgname"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm744 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/license.patch b/license.patch
deleted file mode 100644
index 42abce87a675..000000000000
--- a/license.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 032fdcc..8973cfc 100644
---- a/setup.py
-+++ b/setup.py
-@@ -8,7 +8,7 @@ setup(
- author = "Reynald Affeldt",
- install_requires = ['pygments'],
- packages = ['ssrmint'],
-+ license = 'BSD',
-- license = ['BSD'],
- entry_points = {
- 'pygments.styles': ['ssr = ssrmint:SSRStyle'],
- 'pygments.lexers': ['CoqLexer = ssrmint:SSRLexer'],