summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRickaPrincy2023-12-28 16:13:43 +0000
committerRickaPrincy2023-12-28 16:13:43 +0000
commit82bc2df892624e39c110c8fabd1429b1d23cde84 (patch)
tree7bd132ec145bc2a9e3a8c6509a5590866ae373bc
downloadaur-tcolor.tar.gz
Update AUR package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be8f1caf7e91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tcolor
+ pkgdesc = tcolor is a simple header file that provides you with options to print text in color within the terminal
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/RickaPrincy/TColor.hpp
+ arch = any
+ license = MIT
+ makedepends = cmake
+ source = TColor.tar.gz::https://github.com/RickaPrincy/TColor.hpp/releases/download/v1.0.0/TColor.tar.gz
+ sha256sums = 697e410c550ee639b28f15ad317fac13198e14a6559df644bffb23b1538d0bec
+
+pkgname = tcolor
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fa9e38e398b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: RickaPrincy <rckprincy@gmail.com>
+
+pkgname=tcolor
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="tcolor is a simple header file that provides you with options to print text in color within the terminal"
+arch=('any')
+url="https://github.com/RickaPrincy/TColor.hpp"
+license=('MIT')
+makedepends=("cmake")
+source=("TColor.tar.gz::https://github.com/RickaPrincy/TColor.hpp/releases/download/v$pkgver/TColor.tar.gz")
+sha256sums=("697e410c550ee639b28f15ad317fac13198e14a6559df644bffb23b1538d0bec")
+
+build() {
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file