summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-03-22 17:35:26 +0100
committerAlexander F. Rødseth2022-03-22 17:35:26 +0100
commitedd4069e48e1fef1afd0acdbdf979d1f23cbbaf3 (patch)
tree4264949f0546b52b6f2f0bbe26b72ce1167845ef
parent15a1ce8b460ab5797a0ec00279703e154a870acc (diff)
downloadaur-teaftp.tar.gz
New release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8125ea7d3af0..62b6df2b33d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,13 @@
-# Generated by mksrcinfo v8
-# Wed Jan 16 11:27:01 UTC 2019
pkgbase = teaftp
pkgdesc = Simple, read-only TFTP server
- pkgver = 1.1.1
+ pkgver = 1.3.0
pkgrel = 1
url = https://github.com/xyproto/teaftp
arch = x86_64
- license = MIT
+ license = BSD
makedepends = git
makedepends = go
- source = git+https://github.com/xyproto/teaftp#tag=v1.1.1
- md5sums = SKIP
+ source = git+https://github.com/xyproto/teaftp#commit=27e21c589f95d823c60d0079d02246a3bfcb314f
+ b2sums = SKIP
pkgname = teaftp
-
diff --git a/PKGBUILD b/PKGBUILD
index d4e3e4bfda50..851ef86d92ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=teaftp
-pkgver=1.1.1
+pkgver=1.3.0
pkgrel=1
pkgdesc='Simple, read-only TFTP server'
arch=(x86_64)
url='https://github.com/xyproto/teaftp'
-license=(MIT)
+license=(BSD)
makedepends=(git go)
-source=("git+$url#tag=v$pkgver")
-md5sums=('SKIP')
+source=("git+$url#commit=27e21c589f95d823c60d0079d02246a3bfcb314f") # tag: v1.3.0
+b2sums=(SKIP)
build() {
- cd "$pkgname"
-
- export GO111MODULE=off
- go get -d
- go build -buildmode=pie
+ cd $pkgname
+ go build -buildmode=pie -ldflags="-s -w -extldflags \"${LDFLAGS}\"" -mod=vendor -trimpath -v
}
package() {
- cd "$pkgname"
-
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim: ts=2 sw=2 et: