summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-26 18:02:08 +0200
committerFabioLolix2021-08-26 18:02:08 +0200
commit3d9c84dcb50c77add826a5d42524a65387792453 (patch)
tree1c2d1f11d80d3f334f97dee21b5f7b0563985858
parentf4e9fedb498c80f4c46a00d7ab8f84da1d2642d1 (diff)
downloadaur-ufw-icon-bar.tar.gz
revision
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc64ade7e4e..0c6ae217e6e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = ufw-icon-bar
pkgdesc = System tray icon for ufw
- pkgver = 1
- pkgrel = 6
+ pkgver = r15.gbf67a93
+ pkgrel = 1
+ epoch = 1
url = https://github.com/juanmafont/ufwIconbar
arch = any
license = unknown
+ makedepends = git
depends = yad
depends = ufw
optdepends = gufw: Enables gufw to open when icon is clicked
- source = ufw-icon-bar-1::git+https://github.com/juanmafont/ufwIconbar.git
- md5sums = SKIP
+ source = git+https://github.com/juanmafont/ufwIconbar.git#commit=bf67a93ce02543d4d4472eabd822da495a0de9b1
+ sha256sums = SKIP
pkgname = ufw-icon-bar
-
diff --git a/PKGBUILD b/PKGBUILD
index 95388856b468..3a8cd65cd5eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,28 @@
-# Maintainer: Alif Uzair bin Abd Rahman <riazufila at gmail dot com>
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: Alif Uzair bin Abd Rahman <riazufila at gmail dot com>
# Contributor: Cole Thompson <cole dot thompson at gmail dot com>
+
pkgname=ufw-icon-bar
-pkgver=1
-pkgrel=6
+pkgver=r15.gbf67a93
+pkgrel=1
+epoch=1
pkgdesc="System tray icon for ufw"
arch=('any')
url="https://github.com/juanmafont/ufwIconbar"
license=('unknown')
depends=('yad' 'ufw')
+makedepends=(git)
optdepends=('gufw: Enables gufw to open when icon is clicked')
-source=("$pkgname-$pkgver::git+https://github.com/juanmafont/ufwIconbar.git")
-md5sums=("SKIP")
+source=("git+https://github.com/juanmafont/ufwIconbar.git#commit=bf67a93ce02543d4d4472eabd822da495a0de9b1")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/ufwIconbar"
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -Dm 755 "$srcdir/$pkgname-$pkgver/gufw_icon.sh" "$pkgdir/usr/bin/gufw_icon.sh"
+ cd "${srcdir}/ufwIconbar"
+ install -Dm755 gufw_icon.sh "$pkgdir/usr/bin/gufwicon"
}