summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-02-23 19:19:39 +0530
committerAnkit R Gadiya2018-02-23 19:19:39 +0530
commita56b5210d97ddd93002b530f4f59dcdf1c80cf95 (patch)
tree04a80c999d42e93935eff4b9866d5e49394d2633
parentab81084d69709b80c509c52fb3a4de04614727a6 (diff)
downloadaur-vim-colorscheme-alduin.tar.gz
Version bump 6.0.0, Added License, airline theme
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a24e78fc4772..aa70f60b5e8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
-# Generated by mksrcinfo v8
-# Wed Sep 21 02:54:02 UTC 2016
pkgbase = vim-colorscheme-alduin
pkgdesc = A dark low-contrast Vim colorscheme for Terminal Vim and GUI Vim.
- pkgver = 3.0.0
- pkgrel = 2
+ pkgver = 6.0.0
+ pkgrel = 1
url = https://github.com/AlessandroYorba/Alduin
arch = any
license = MIT
- source = https://github.com/AlessandroYorba/Alduin/archive/v.3.0.0.tar.gz
- md5sums = 6165e7167bd8596a4e13135b17ff459b
+ source = vim-colorscheme-alduin-6.0.0.tar.gz::https://github.com/AlessandroYorba/Alduin/archive/v6.0.0.tar.gz
+ source = LICENSE
+ md5sums = eed9003b5ff421a005e13215b847718b
+ md5sums = b1649899e6ed82950e52f46a3e9656de
pkgname = vim-colorscheme-alduin
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..79c89161099f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+Copyright (c) 2017 Alessandro Yorba
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index aed71500492a..cf066057be57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: George Angelopoulos <george@usermod.net>
+# Maintainer: Ankit R Gadiya <arch@argp.in>
+# Contributor: George Angelopoulos <george@usermod.net>
+
pkgname=vim-colorscheme-alduin
-pkgver=3.0.0
-pkgrel=2
+pkgver=6.0.0
+pkgrel=1
pkgdesc="A dark low-contrast Vim colorscheme for Terminal Vim and GUI Vim."
arch=('any')
url="https://github.com/AlessandroYorba/Alduin"
license=('MIT')
-source=("https://github.com/AlessandroYorba/Alduin/archive/v.${pkgver}.tar.gz")
-md5sums=('6165e7167bd8596a4e13135b17ff459b')
-_name=Alduin
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/AlessandroYorba/Alduin/archive/v${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('eed9003b5ff421a005e13215b847718b'
+ 'b1649899e6ed82950e52f46a3e9656de')
package() {
- cd "$_name-v.$pkgver"
- install -Dm644 colors/alduin.vim "$pkgdir/usr/share/vim/vim80/colors/alduin.vim"
-}
+ install -Dm755 "Alduin-${pkgver}/colors/alduin.vim" \
+ "$pkgdir/usr/share/vim/vimfiles/colors/alduin.vim"
+ install -Dm755 "Alduin-${pkgver}/autoload/airline/themes/alduin.vim" \
+ "${pkgdir}/usr/share/vim/vimfiles/autoload/airline/themes/alduin.vim"
-# vim:set ts=2 sw=2 et:
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}